• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Devaka Cooray
  • Ron McLeod
  • Jeanne Boyarsky
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Martijn Verburg
  • Frits Walraven
  • Himai Minh

application.xml not validate:

 
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Member Since: Aug 19, 2004



appplication.xml is failingh validation in weblogic 8.1
Posted: 10 Sep 2004 09:20 AM
Reply

i am deploying an application on weblogic 8.1 SP3 which is also running on JBOSS:
when deploying the .ear file in the console deploy application option this error comes up :


weblogic.management.DeploymentException: Error while loading descriptors: Error processing file 'META-INF/application.xml'. weblogic.xml.process.XMLProcessingException: XML document does not appear to contain a properly formed DOCTYPE header - with nested exception: [weblogic.xml.process.ProcessorFactoryException: XML document does not appear to contain a properly formed DOCTYPE header] - with nested exception: [weblogic.xml.process.ProcessorFactoryException: XML document does not appear to contain a properly formed DOCTYPE header


i had this error before and thought becuase there was NO DOCTYPE header probably thast the problem now my application.xml looks like this. :





<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE application SYSTEM "/home/dtdresource/application_1_3.dtd">
<application>
<display-name>Deployed EJBs for all datasets</display-name>
<module>
<java>powerCor_clientServerLib.jar</java>
</module>

<module>
<java>xmlrpc-1_2-b1.jar</java>
</module>
<module>
<java>nekohtml.jar</java>
</module>
<module>
<java>ejb_client_configs.jar</java>
</module>
<module>
<java>installedModules.jar</java>
</module>
<module>
<java>joins.jar</java>
</module>
<module>
<java>menus.jar</java>
</module>
<module>
<java>queries.jar</java>
</module>
<module>
<java>statemachines.jar</java>
</module>

< there were some more modules but for conveneince of reading this post have been deleted>
</application>


if anybody can reply i will really appreciate it : i need to run this appictation on weblogic.
btw: this XML file was generated in a java classnot using xml parsers but fileoutputstream.. bnut i dont thik it shouldnt matter.

also one more thing : the weblogic-application.xml is empty it only has the weblogic-application tags and thats it and it also has the DocTYPE.. its empty becuase i thought it was optional and there was nothing server specific in the application
 
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Its possibly complaining because it cant find application_1_3.dtd. Try this instead (unless you have a reason for using SYSTEM?):

 
We don't have time for this. We've gotta save the moon! Or check this out:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic