• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

? where's my GUI?

 
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi,
I don't know what it is that I may have done but now when I compile, a java window does not open.
My gui is not run.
I'm using jbulder 7.
what could have done this..?
 
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
make sure that you are invoking setVisible(true) method.besides setSize() for your frame.
It's difficult to guess whether it's code problem or JBuilder problem.you will get help,if you can post your code.
 
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Or frame.show()
Bill
 
Drake Silver
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi..thanks for the replies.
I don't know what it is that I may have done.
I also don't know what code you want...
so I posted the code from the application configuration.

It is set to visible, and when I added .show() it didn't seem to affect anything.
any more ideas?
 
Drake Silver
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
any other ideas?
I can't work on this without the Gui...
The only thing I remember doing was adding
a JFileChooser.
After that the Compiled Code no longer ranin a window
 
Drake Silver
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
well...
why don't to make sure that the java file being compiled is the main class.
meaning, go into project properties and make sure your main java file is the one being compiled.
good luck
 
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
So, ya got it all figured out?
 
Drake Silver
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hey..what happened..?
After I told myself what to do..
I went and did it.
Then Iposted back a reply that said I had fixed my problem..wierd..?
I could of sworn that my follow up post made it through..
anyway, yes, everything's working fine now.
thanks for asking
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic