• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Java Pet Store Application

 
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am trying to install the Java Pet Store application. After setting the environment variables, I tried to start the cloudscape database server but I got a whole list of errors like:
Wed Mar 28 13:21:39 GMT+08:00 2001: [RmiJdbc] COM.cloudscape.core.JDBCDriver registered in DriverManager
Wed Mar 28 13:21:39 GMT+08:00 2001: [RmiJdbc] Binding RmiJdbcServer...
Wed Mar 28 13:21:39 GMT+08:00 2001: [RmiJdbc] No installation of RMI Security Manager...
Please advise how I can get around this problem
 
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello!
i think it is not an error.why don't you continue running yr.application and see?
 
Anupama Dhir
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by NageswaraRao Karra:
Hello!
i think it is not an error.why don't you continue running yr.application and see?


When it continues I get the following errors:
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:397)
at java.net.ServerSocket.<init>(ServerSocket.java:170)
at java.net.ServerSocket.<init>(ServerSocket.java:82)
at sun.rmi.transport.proxy.RMIDirectSocketFactory.createServerSocket(RMI
DirectSocketFactory.java:30)
at sun.rmi.transport.proxy.RMIMasterSocketFactory.createServerSocket(RMI
MasterSocketFactory.java:312)
at sun.rmi.transport.tcp.TCPEndpoint.newServerSocket(TCPEndpoint.java:55
9)
at sun.rmi.transport.tcp.TCPTransport.listen(TCPTransport.java:200)
at sun.rmi.transport.tcp.TCPTransport.exportObject(TCPTransport.java:172
)
at sun.rmi.transport.tcp.TCPEndpoint.exportObject(TCPEndpoint.java:319)
at sun.rmi.transport.LiveRef.exportObject(LiveRef.java:119)
at sun.rmi.server.UnicastServerRef.exportObject(UnicastServerRef.java:12
5)
at sun.rmi.registry.RegistryImpl.setup(RegistryImpl.java:95)
at sun.rmi.registry.RegistryImpl.<init>(RegistryImpl.java:81)
at java.rmi.registry.LocateRegistry.createRegistry(LocateRegistry.java:1
67)
at RmiJdbc.RJJdbcServer.register(RJJdbcServer.java:155)
at RmiJdbc.RJJdbcServer.main(RJJdbcServer.java:243)
Please advise.
 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The first set of messages are informational only.
The stack trace seems to be showing that the
default port RmiJdbc uses (1099) is in use.
Some Windows apps (Personal Web Server, for one)
may be using that port already. You can pick
an alternate port for RmiJdbc by adding
-port # to the command line, like this:
java RmiJdbc.RJJdbcServer -port 1088 COM.cloudscape.core.JDBCDriver
Just be sure to include the port # on your JDBC URLs
as well, i.e.:
jdbc:cloudscape:rmi://localhost:1088/mydb
Hope this helps,
Ames Carlson
ames.carlson-at-informix.com
 
Those are the largest trousers in the world! Especially when next to this ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic