Win a copy of Beginning Java 17 Fundamentals: Object-Oriented Programming in Java 17 this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Problems with Cocoon and Struts

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
I'd like to write web-application based on Model 2X, but I can't integrate libraries Cocoon and Struts. I'm using
server Tomcat 4.0.6, Struts 1.1, Cocoon 2.1, and Struts - Cocoon Plug-in (struts-cocoon.0.2.jar).
1) I'm wondeing if each application need its own configuration file sitemap.xmap or all applications are described in ONE global configuration
file (located in $CATALINA_HOME\webapps\cocoon - directory).
2) I tried to write very simple application based on Cocoon. I created application
directory ($CATALINA_HOME\webapps\cookbook) - inside of it I created two very simple
xml files, and configuration file - sitemap.xmap.
Inside of my local sitemap.xmap I added this code:
************sitemap.xmap**********************
<map ipeline>
<map:match pattern="cookbook/">
<map:generate type="directory" src="cookbook">
<map arameter name="include" value=".*\.xml"/>
</map:generate>
<map:transform src="stylesheets/system/directory2html.xslt"/>
<map:serialize/>
</map:match>
</map ipeline>
**********************************************
When I tried to test it, and wrote: http://localhost:8080/cookbook/ I expected
the list of my *.xml files, but I got 404 - Apache Tomcat Error:
************Apache Tomcat/4.0.6 - HTTP Status 404 - /cookbook/********
description: The requested resource (/cookbook/) is not available
***********************************************************************
My Cocoon is installed in directory: $CATALINA_HOME\webapps\cocoon.
What I'm doing wrong? Should I modify global sitemap.xmap file (If Yes - How?) ?
I know that that are very basic problems - but those are my first step in Cocoon. I'm asking for help.
Best regards
Mariusz Wojcik
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic