This week's book giveaway is in the HTML Pages with CSS and JavaScript forum.
We're giving away four copies of Testing JavaScript Applications and have Lucas da Costa on-line!
See this thread for details.
Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

orion BeeServlet problem

 
Ranch Hand
Posts: 424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am very close to the servlets, so I installed the orion-server
It is up and running, showing the DateServlet correct.
BeeServlet.java compiled to BeeServlet.class no problem.
The JavaRanchCommon.zip copied to JavaRanchCommon.jar to my
orion/lib directory.
BeeServlet.class copied to the announced place and giving:
Html error: page not found.
Here is an excerpt from default-web-access.log:
127.0.0.1 - - [31/May/2001:08:52:23 +0100] "GET /moo.html HTTP/1.1" 200 305
127.0.0.1 - - [31/May/2001:08:56:46 +0100] "GET /servlet/DataServlet HTTP/1.1" 404 143
127.0.0.1 - - [31/May/2001:08:56:57 +0100] "GET /servlet/DateServlet HTTP/1.1" 200 31
127.0.0.1 - - [31/May/2001:09:06:34 +0100] "GET /servlet/BeeServlet HTTP/1.1" 404 142
127.0.0.1 - - [31/May/2001:09:07:11 +0100] "GET /servlet/BeeServlet HTTP/1.1" 404 142
127.0.0.1 - - [31/May/2001:09:07:29 +0100] "GET /servlet/ HTTP/1.1" 404 132
127.0.0.1 - - [31/May/2001:09:08:27 +0100] "GET /servlet/BeeServlet HTTP/1.1" 404 142
What do I miss?
<h1>Problem solved:</h1> I did a stupid error.
I copied BeeServlet.java in place of BeeServlet.class.
Now I got a a-buzz-buzz
[This message has been edited by Peter Gragert (edited May 31, 2001).]
 
Ranch Hand
Posts: 349
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Peter for pointing out a possible error
Rashid
    Bookmark Topic Watch Topic
  • New Topic