• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

WSDL generation issue for the same webservice deployment

 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have deployed a web service and I am using Axis jars (axis1.4.jar, axis2-kernel-1.3.jar, axis-ant.jar). The WSDL generated (after I click in the WSDL link) next to the web service name has some discrepancies from the WSDL generated before.

WSDL snippet of the old WSDL...

<wsdl:message name="getUserDetailsRequest">
<wsdl :p art name="credential type="tns1:Credential"/>
<wsdl :p art name="userDetailsCriteria" type="tns3:userDetailsCriteria"/>
</wsdl:message>
<wsdl:message name="userDetailsResponse">
<wsdl :p art name="getUserDetailsReturn" type="tns3:userDetailsResponse"/>
</wsdl:message>

<wsdl :p ortType name="UserServices">
<wsdl peration name="getUserDetails" parameterOrder="in0 in1">
<wsdl:input name="getUserDetailsRequest" message="impl:getUserDetailsRequest"/>
<wsdl utput name="userDetailsResponse" message="impl:userDetailsResponse"/>
</wsdl peration>
</wsdl :p ortType>

WSDL snippet of the new WSDL...
<wsdl:message name="getUserDetailsRequest">
<wsdl :p art name="in0" type="tns1:Credential"/>
<wsdl :p art name="in1" type="tns3:userDetailsCriteria"/>
</wsdl:message>
<wsdl:message name="userDetailsResponse">
<wsdl :p art name="getUserDetailsReturn" type="tns3:userDetailsResponse"/>
</wsdl:message>

<wsdl :p ortType name="UserServices">
<wsdl peration name="getUserDetails" parameterOrder="in0 in1">
<wsdl:input name="getUserDetailsRequest" message="impl:getUserDetailsRequest"/>
<wsdl utput name="userDetailsResponse" message="impl:userDetailsResponse"/>
</wsdl peration>
</wsdl :p ortType>

Notice the change in the "part name" of the old and new WSDls. There has been no change in the WSDD. Doe to this the old clients which I had created using the old WSDL does not work. Could anybody please commnet on why this happens and the fix? Thanks in advance.
[ November 06, 2008: Message edited by: SGC Manorite ]
 
Ranch Hand
Posts: 2187
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Doe to this the old clients which I had created using the old WSDL does not work.



Could you reword this sentence? It does not make any sense.

Thanks.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic