• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Problem while Creating Project by using mvn archetype:create -DgroupId=com.mycompany

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have installed(Version 2.0.4-maestro-1.1) and trying to create Project by using: mvn archetype:create -DgroupId=com.mycompany. But I am getting following problem:

[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'archetype'.
[INFO] org.apache.maven.plugins: checking for updates from central
[WARNING] repository metadata for: 'org.apache.maven.plugins' could not be retri
eved from repository: central due to an error: Error transferring file
[INFO] Repository 'central' will be blacklisted
Downloading: http://repo.mergere.com/maven2/org/apache/maven/plugins/maven-compi
ler-plugin/2.0/maven-compiler-plugin-2.0.pom
[WARNING] Unable to get resource from repository central (http://repo.mergere.co
m/maven2)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

GroupId: org.apache.maven.plugins
ArtifactId: maven-compiler-plugin
Version: 2.0

Reason: Unable to download the artifact from any repository

org.apache.maven.plugins:maven-compiler-plugin om:2.0

from the specified remote repositories:
central (http://repo.mergere.com/maven2)


[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 42 seconds
[INFO] Finished at: Thu Nov 16 15:11:43 IST 2006
[INFO] Final Memory: 1M/2M
[INFO] ------------------------------------------------------------------------

Please help friends.
 
Saloon Keeper
Posts: 27816
196
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It looks like Maven could not download needed components from the mergere repository. I checked, and I got the indicated file to download myself, so mostly likely you had network issues. Try it again and see if the problem still exists. If so, get ahold of a network tech and ask why you can't get access to that location.
 
Ceenu Reddy
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Actually we are behind a firewall in my office, we will have to set up Maven to understand that. To do this, I have changed <your-homedirectory>/.m2/settings.xml file with the following content:

<settings>
<proxies>
<proxy>
<active>true</active>
<protocol>http</protocol>
<host>proxy.mycompany.com</host>
<port>8080</port>
<username>your-username</username>
<password>your-password</password>
</proxy>
</proxies>
</settings>

Thank you very much Tim.
 
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
No luck for me! Can anybody help me out? Thanks in advance.
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Vincent, it might help if you described your situation a little more, including what you have tried (post any config changes) and what errors you got. Otherwise, all we can say is do what Ceenu did to get around the proxy server issues.
 
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Ceenu Reddy wrote:Actually we are behind a firewall in my office, we will have to set up Maven to understand that. To do this, I have changed <your-homedirectory>/.m2/settings.xml file with the following content:

<settings>
<proxies>
<proxy>
<active>true</active>
<protocol>http</protocol>
<host>proxy.mycompany.com</host>
<port>8080</port>
<username>your-username</username>
<password>your-password</password>
</proxy>
</proxies>
</settings>

Thank you very much Tim.



the above solution works for me. thanks
 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear Vincent.
I had similar problem. I reconfigured the settings.xml file too.But nothing worked till i switched off the windows firewall . After that the things were working smoothly
 
reply
    Bookmark Topic Watch Topic
  • New Topic