• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Persistent problem

 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi everyone!

I have the following code inside a method of a POJO class
(the method is called from a jsf back bean object):



When the method is called everything works fine (No exception and while debugging the normal execution path is taken) but the register is not inserted in the DB.

The environment is:
Server: Weblogic 10.3
DB Server: MSSQL 2000
Driver: BEA SQL XA (BEA SQL NON XA = same behavior)
JPA Provider: Hibernate

In persistence.xml:
data source: jta data source (hosted by the WebLogic)
transaction type: JTA
Properties:
hibernate.dialect = org.hibernate.dialect.SQLServerDialect
hibernate.transaction.factory_class = org.hibernate.transaction.JTATransactionFactory

Any idea? Why the register isn't inserted like expected?

Thank you very much!
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic