Win a copy of Spring Boot in Practice this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Building Seam projects in Eclipse

 
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey guys,
I am sorry if this should be in a different section but...

I created a Seam project a little while ago, and it generated its own ant build script (something I am unfamiliar with.)
Every time I build my project, I get 100 or so errors report from Eclipse, until I do a Project --> Clean....then everything seems to be fine.
This is just a small annoyance that I can't figure out. Here is the generated ant script...



Any thoughts?

Thanks!
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Could you post the first few errors that you get? Also, how did you create the Seam project? Via Eclipse? Via seamgen? I assume that when you say you build your project that you are doing that in Eclipse. If so, is your project configured to use the Ant script for the build? I'd hate to spent time debugging the Ant script if Eclipse is not even using it.
 
Ryan Waggoner
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey Peter,
I am using seam gen to create the project. And I did make sure Eclipse is really using the ant script that seam gen created.

I attached a ss of my errors. You will notice that they are all occurring in the file that I currently had open when I built the project. None of these errors exist after cleaning my project.

Thanks!
antBuildErrors.JPG
[Thumbnail for antBuildErrors.JPG]
Ant Build Errors
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Those are all Java compilation errors. Looks like the classpath is not being set properly for some reason. Why, I don't know. Try adding the -v option to the ant build options (I think you can do that) and look at the ant output, that might give some clues.
 
reply
    Bookmark Topic Watch Topic
  • New Topic