This week's giveaway is in the Spring forum.
We're giving away four copies of Microservices Testing (Live Project) and have Chris Love & Andres Sacco on-line!
See this thread for details.
Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Calling Stored Procedures from Spring

 
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When I try to call a stored procedure from the spring framework, my log files keep increasing in size due to a lot of writes to it and then after about 30 mins I get OutOfMemoryError.
I am using the StoredProcedure class from the spring framework.

Here's what I have so far

Oracle Stored Procedure


My StoredProcedure class
Note the commented out line "setFunction(true)". If I uncomment it, I get a SQLException with the following message :
I thought that setFunction(true) should only be for functions. But since I have a procedure, I shouldn't be setting it correct?

My DAO which calls the above StoredProcedure class



Any help is appreciated.

Thanks in advance..
 
Russell Peters
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Update:

I searched google a lot and came across one post which indicated that the ojdbc14 jar file that the server might be using may have a bug which may cause the above issue.

I was using tomcat 6.0.13 which was using ojdbc14 - version 10.1.0.2. I, then ran the code on the weblogic instance and everything worked. Weblogic was using 10.2.0.2 version of the ojdbc14.

I copied over the 10.2.0.2 in my tomcat installation and everything worked. The latest ojdbc14 is at 10.2.0.4 -- I haven't tested it with the latest but if anyone else is experiencing a similar problem, you may want to check out the ojdbc14 versions before mucking around in the code.

Good Luck.

 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic