• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

JDBC connection in Oracle Application Server 10g

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys,

I have a war file with a simple JDBC connection. I didnt use DATA SOURCE coz im only using one table. I have my application developed using myeclipse and apache tomcat
which is perfectly connecting to Oracle 10g Database. But when i uploaded the war file in the application server and tried to run the web app, it seems
like its not selecting/updating/inserting into the table. I checked the logs but did not found any significant JDBC error. I used ojdbc14.jar in my
web app.


Please help.


thanks,
yan
 
yan yan
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
this is now ok.

MyEclipse tomcat is allowing the executeQuery on insert/update statements. But doesnt have any error raised on Oracle Application Server release 3.
I tried to deploy it on OC4J standalone and found the error "SQL string is not Query".

unfortunately,there was one statement in my code that uses ExecuteQuery on update statement.




Many thanks.



 
My, my, aren't you a big fella. Here, have a tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic