• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

SSL configuration problem in Jboss 5.1.0

 
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I configured SSL in Jboss 5.1.0. It was possible for me to access my application available inside war file through http as well https.

Currently i have my applications in two war files A and B deployed under default/deploy directory. Is it possible to access applications in B.war using only https and A.war using only http.

Please suggest

 
Prakash Kumar M
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please let me know any suggestions
 
Prakash Kumar M
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
any help
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Doesn't http://localhost:8080/app1 and https://localhost:8443/app2 work? Or are you saying that you want to prevent access to app1 through https?
 
Prakash Kumar M
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Jai for replying.

Yes you are right, my app1 is website and app2 is my shopping cart application.

So i have a requirement to run SSL only for app2 and not for app1 (website pages)

Since SSL is configured at server level, https is getting activated to app1 also.

Can you please help me on this.
 
Prakash Kumar M
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please help
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Prakash,

Your reply already contains the answer:

Prakash Kumar M wrote:
Since SSL is configured at server level, https is getting activated to app1 also.



It's a server level setting and i don't know of any way to have app1 (on the same server instance) not available on https.
 
Ranch Hand
Posts: 1179
Mac OS X Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The only solution I can see is to start two nodes of your JBoss server, which are configured with and without SSL - or have two JBoss instances running.
 
The only taste of success some people get is to take a bite out of you. Or this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic