Win a copy of JDBC Workbook this week in the JDBC and Relational Databases forum
or A Day in Code in the A Day in Code forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

problem in calling a web service hosted on tomcat from BEA weblogic portal

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have a web service hosted on apache tomcat 5.5(running on port : 8080). I tried to call that web service from BEA weblogic portal through a JSP potlet. I got an error saying -



Can any one please suggest me a solution to my problem. When I tried to call a web service which was created using weblogic(running on port : 7001), it was working fine. Is there any way to call a web service hosted on tomcat server from web logic portal.

Thanks in advance,
Tiijnar
 
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is the web service that is hosted in tomcat working correctly ? If the binding is soap you can use a tool like soap UI to check this.
 
ranjeet amancha
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi deepak,
My web service is using soap binding. I have tested it with eclipse and other tools also. It is working well and good.
Do you have any idea of calling a web service running on a different server, from web logic. I find it difficult. Can you please help me out.

-Tiijnar
 
Deepak Bala
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My guess is that a custom tag is probably misbehaving. Not sure what is going on though. Perhaps you should check the JSP file again for syntax errors.
 
If I'd had more time, I would have written a shorter letter. -T.S. Eliot such a short, tiny ad:
ScroogeXHTML 9.0 - RTF to HTML5 and XHTML converter
https://coderanch.com/t/731949/ScroogeXHTML-RTF-HTML-XHTML-converter
    Bookmark Topic Watch Topic
  • New Topic