• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

JSP Exception only on JBoss not Tomcat?

 
Ranch Hand
Posts: 399
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi, when I try to deploy some JSP-s on the JBoss 5.G.A, I get following exception :


There is no much information about this issue on web. I try something like it is described in this article, but doesn't help much. I appreciate any help. Thanks!
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
What JAR files are in your WEB-INF/lib directory? Do you perhaps have the Jasper JAR file there? If so, remove it.
 
Goran Markovic
Ranch Hand
Posts: 399
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I believe that Eclipse make problems, because I publish application of JBoss, using some plug-ins. Eclipse automatically add ligraries into WEB-INF/lib, like:
servlet.jar, jsp.jar, jstl.jar, and export it into deploy directory of Jboss. I am sure that eclipse-jboss plug-ins, create problem. Sometimes (mostly) it want even to export project I marked to be deployed on JBoss. Is there maybe some other bug-fixed plug in so I can test my application in eclipse, starting JBoss server from eclipse?
Thanks
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The root cause of this issue, which is caused by jar files containing javax.servlet.* in the application's packaging, suddenly showing up prominently in AS-5.1 is this. That fix will be available in the next release of AS. In the mean time, remove the jar file(s) containing javax.servlet.* classes, from your application packaging.
 
Goran Markovic
Ranch Hand
Posts: 399
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks guys for your cooperation. Omitting classes (packages) added by eclipse itself resolve the problem.
 
I need a new interior decorator. This tiny ad just painted every room in my house purple.
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic