Win a copy of Escape Velocity: Better Metrics for Agile Teams this week in the Agile and Other Processes forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Frank Carver
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • fred rosenberger

Adding Breakpoints to JSP's in Eclipse 3.5

 
Ranch Hand
Posts: 483
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Everyone,

I am using Eclipse 3.5 (Galileo) package and I would like to know that is it possible to put breakpoints in JSP's to debug them? I have tried adding breakpoints in some JSP's, but I get the error message of something like "Cannot add a breakpoint here" or something!!! Is there a plug in that can do it?
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Have you created a server (within Eclipse) and associated your web application project with a server? Oh, and did you create a Dynamic Web Application project? I think all of those things have to be in place before you can debug JSPs.
 
Somnath Mallick
Ranch Hand
Posts: 483
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Yes I have created a JBoss and a Tomcat 6.0.20 server within eclipse. I also have created a Dynamic Web Project and still i am unable to add breakpoints to JSP's.
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Just to double check, I tried it again and it works for me - Eclipse stops at the breakpoint in my JSP. If you want to know what I did, you can read the help text in Eclipse on debugging JSPs (it's under Web Tools Platform User's Guide, "Debugging a JSP file under a server")
 
Ranch Hand
Posts: 686
Netbeans IDE Chrome Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I m separate user from the original thread originator -

I am using my own Ant script to build and deploy to Tomcat. I use Sysdeo plugin in Eclipse to start and stop Tomcat. But it is strange the debug does not work...
What can be the problem? The only thing I see different is that I do not use the Eclipse Server (Tomcat).

The strange part is that this worked some time back!!
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Vyas, please post your question in a new topic.
reply
    Bookmark Topic Watch Topic
  • New Topic