Win a copy of TDD for a Shopping Website LiveProject this week in the Testing forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

error setting up custom user registry in WAS

 
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All ,
I am trying out the usage of custom user registry in WAS6.1 .
Setting the WAS properties to use the pre-provided File-based user registry worked fine .
Moving on I tried to use the IBM DB2 custom user registry.
I placed the required jars - db2jcc.jar,db2jcc_javax.jar,
db2jcc_license_cu.jar ,sas.jar and wssec.jar in the <WebSphere_root>/lib/ext),
i also added the jar containing my custom registry implementation in the same ext directory .
However I get a ClassNotFound exception when UserRegistryImpl tries to load my custom registry class during server start up.
Is there anything I am missing in this? Why is the classloader unable to load the registry class?
Having a look at the classloaders view in admin console reveals that all the necessary jars are in the classpath of the WAS Extension Loader .
Any pointers on this would be really helpful .
Thanks.
 
Let me tell you a story about a man named Jed. He made this tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic