• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

openoffice 3.1 Defective java runtime error

 
Ranch Hand
Posts: 510
Google Web Toolkit Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,
I managed to install the OOo 3.1 SDK and OOo 3.1 on my linux box to use them for development of java openoffice addon.
however there is a problem which causing me real headaches !
I use Netbeans IDE to develop a openoffice java Addon. I set my java OOo addon project to use same JDK 6 used when installing OOo 3.1
openoffice ->options-Java it set to use same JDK 6.
now when i run my OOo from netbeans IDE i get this evil error message : defective java runtime! etc..
below is also the debug log from netbeans when running the OOo addon application.
can someone point me what could be this problem about? i did't get this problem before ,but i guess when i upgraded to OOo 3.1 from OOo 3.0 i no more can run my openoffice addon from netbeans!
any help is much appreciated.

reply
    Bookmark Topic Watch Topic
  • New Topic