• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Unable to start Weblogic Server using wlserver

 
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all....

I am using Weblogic 8.1.

I am trying to run the following ant task to start weblogic server. But it doesnt startup.

However, I am able to shutdown the server using the below script by changing the action to "shutdown".

<wlserver policy="${policy.path}" dir="${config.path}" beahome="${bea.home}" weblogichome="${weblogic.home}" servername="${server.name}" domainname="${domain.name}" username="${username}" password="${password}" host="${host.ip}" port="${host.port}" action="startup"/>

 
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Change the action to start. Let us know if that helps
 
Anoop Nair
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks for the suggestion Deepak...

I tried by changing the action to start...

But in this case i get the follwing exception:

weblogic.management.configuration.ConfigurationException: Invalid MBeanType: ApplicationConfiguration - with nested exception




I searched this on google.... But the only thing i could find out was that it may be a problem of classpath.
I already have weblogic.jar in my classpath...

Is any other jar also needed in the classpath...??
 
Deepak Bala
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
To my knowledge, you do not need any other jar. Can you post a more detailed stack trace ?
 
Anoop Nair
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Below is the complete stacktrace:


[wlserver] <Sep 2, 2009 6:55:18 AM EDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 1.4.2_08-b03 from Sun Microsystems Inc.>
[wlserver] <Sep 2, 2009 6:55:18 AM EDT> <Info> <Configuration Management> <BEA-150016> <This server is being started as the administration server.>
[wlserver] <Sep 2, 2009 6:55:18 AM EDT> <Info> <Management> <BEA-141107> <Version: WebLogic Server 8.1 SP5 Mon Sep 19 23:06:54 PDT 2005 641358
[wlserver] WebLogic XMLX Module 8.1 SP5 Mon Sep 19 23:06:54 PDT 2005 641358 >
[wlserver] <Sep 2, 2009 6:55:18 AM EDT> <Notice> <Management> <BEA-140005> <Loading domain configuration from configuration repository at C:\bea\user_projects\domains\MyDomain\.\config.xml.>

[wlserver] ***************************************************************************
[wlserver] The WebLogic Server did not start up properly.
[wlserver] Exception raised: 'weblogic.management.configuration.ConfigurationException: Invalid MBeanType: ApplicationConfiguration - with nested exception:
[wlserver] [weblogic.management.configuration.ConfigurationException: Invalid MBeanType: ApplicationConfiguration]'
[wlserver] Reason: weblogic.management.configuration.ConfigurationException: Invalid MBeanType: ApplicationConfiguration - with nested exception:
[wlserver] [weblogic.management.configuration.ConfigurationException: Invalid MBeanType: ApplicationConfiguration]
[wlserver] ***************************************************************************

 
Deepak Bala
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hmm... that does not say much. There are posts out there that say this is a classpath problem. Pretty weird error to display for a classpath problem
 
Anoop Nair
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Could it be anything related to the config file...???

Or is any other jar required to be part of the classpath???
 
Deepak Bala
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
To my knowledge 8.1 does not need any other jar in the class path. I am stumped
reply
    Bookmark Topic Watch Topic
  • New Topic