• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

Weblogic JAAS BEA-101020 No Configuration was registered that can handle the configuration

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

A) I am trying to run JAAS on Weblogic. We have got our own login module developed based on JAAS specification.

I have created jas.config which is as follows:
abcjaas {
<pkg>.DBLoginModule required
};

which I have included in the system properties as
set JAVA_OPTIONS=%JAVA_OPTIONS% -Djava.security.auth.login.config=D:\BeaWL\jaas.config

B) I had also tried setting this
set JAVA_OPTIONS=%JAVA_OPTIONS% -Dlogin.configuration.provider=com.bea.common.security.jdkutils.JAASConfiguration. This I have also tried configuring in the java.security file in the JDK folder.

While in Java code, it precisly throws error here on this statement:


loginContext = new LoginContext("abcjaas", callHandler);


But for all the above trials, it gives the same error as follows:

C)
Inside : Authenticator ::authenticateUser()....
<Sep 10, 2009 2:32:49 PM IST> <Error> <HTTP> <BEA-101020> <[weblogic.servlet.internal.WebAppServletContext@609547 - appName: CommercialLines_EAR', name: 'App', context-path: '/App', spec-version: '2.5'] Servlet failed with Exception
java.lang.IllegalArgumentException: No Configuration was registered that can handle the configuration named abcjaas
at com.bea.common.security.jdkutils.JAASConfiguration.getAppConfigurationEntry(JAASConfiguration.java:124)
at javax.security.auth.login.LoginContext.init(LoginContext.java:243)
at javax.security.auth.login.LoginContext.<init>(LoginContext.java:403)
at <pkg>.Authenticator.authenticateUser(Authenticator.java:38)
at <pkg>.LoginFilter.doFilter(LoginFilter.java:40)
Truncated. see log file for complete stacktrace
>


D) Kindly help, the Weblogic 10.3.0.0 running on JDK1.6 -Sun provided. I am not using the JDK1.6 in WL10.3 or its Jrockit1.6.

Please let me know the resolution.


Cheers,
-Vishal Kumar

 
reply
    Bookmark Topic Watch Topic
  • New Topic