• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Upload servelet issues

 
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi, i got a project that involves uploading file using a servlet. searching on google I found the "commons file upload " of apache. done it, added jar files.

commons-file-upload-1.2.1-bin and
commons-lang-2.4-bin.

when i first ran the application, it was successful until loading the loading of the file. when i tried to upload it, this error pops up

java.lang.NoClassDefFoundError: org/apache/commons/fileupload/FileItemFactory
java.lang.Class.getDeclaredConstructors0(Native Method)
java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
java.lang.Class.getConstructor0(Class.java:2699)
erThread.java:112)
.
.
.
java.lang.Thread.run(Thread.java:619)


so i figured that maybe i did not add the jar files to the server. i opened the server and added some jar files
(C:\Program Files\jboss-4.0.5.GA\server\default\lib) I put it there because i seen many jar files there(i think i will be scolded in this....).

i ran the application again. but this time it yielded a differend error.


java.lang.NoClassDefFoundError: org/apache/commons/io/output/DeferredFileOutputStream
org.apache.commons.fileupload.disk.DiskFileItemFactory.createItem(DiskFileItemFactory.java:196)
org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.java:358)
org.apache.commons.fileupload.servlet.ServletFileUpload.parseRequest(ServletFileUpload.java:126)
ph.com.mobility.projects.model.EprocUploadServlet.doPost(EprocUploadServlet.java:41)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)


what does this one means? do i need to download additional jar files?

done from netbeans 6.5 and Jboss as the server.


here is the code of the file upload servlet.




 
Rancher
Posts: 43028
76
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The Commons FileUpload library needs the Commons IO library in order to work. Luckily, the Apache package names are pretty consistently named, so as you get more experienced you'll be able to see what's missing just by looking at the error message.
 
Led Estonilo
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
thank you very much. yeah it resolved the problem but a new problem arises lol. Ill post a new thread
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic