• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Basic Authentication on a Web Service [WebSphere 7 for developer]

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,
I have a problem to active/configure the basic authentication on a web service with WebSphere 7. I explain me:

I have created a test web service very standard with the web service interface:
and the web service endpoint:
You can see I want that only users in group AXS_AA could access my method getParameter.
Next I have create the ejb-jar.xml:
and the application.xml contains the security-roles.
You can see it is a very simple and standard web service nothing are special, etc..

Ok, next I have compiled classes and created the EAR file. After that I have used the tool endptenabler myEAR.ear to create the http_router for acceding the wsdl url. I don't have modify any descriptors created by this tool.
Finally I have deployed the EAR in WebSphere 7. All thing was running and I can access the wsdl url of the web service.

Then to active the security I have check the checkbox Enable application security of the Global Security with the administration console of Websphere and I have mapped an user to the group AXS_AA for my application.

Now is the problem:
I have created a very simple web service client with NetBeans:
You can see, first I access the web service and then I want to add to the requestContext the credential (username and password) to authenticate to the webservice but the authentication doesn't work and I become the following error:

Now I want to know how I can active/configure the basic authentication and send my credential to be able to access the web service method.
Just for information all thing I have done work correctly with JBoss, Sun Glassfish and Oracle WebLogic but I cannot find what I must to do for WebSphere.

Thanks in advance.
Cyrill
 
my overalls have superpowers - they repel people who think fashion is important. Tiny ad:
a bit of art, as a gift, that will fit in a stocking
https://gardener-gift.com
reply
    Bookmark Topic Watch Topic
  • New Topic