This week's book giveaway is in the Reactive Progamming forum.
We're giving away four copies of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams and have Adam Davis on-line!
See this thread for details.
Win a copy of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams this week in the Reactive Progamming forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

Web service with Eclipse + AXIS2

 
Ranch Hand
Posts: 268
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am trying to build a Bottom Up web service using Eclips3.x + AXIS + JBoss 4.2; and getting following in that process;

IWAB0489E Error when deploying Web service to Axis runtime
axis-admin failed with {http://xml.apache.org/axis/}HTTP (404)/WebServiceProject/services/AdminService

Please let me know if you have any suggestion to solve this.


thnx....
 
Deepika Joshi
Ranch Hand
Posts: 268
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
By following other post, I have selected AXIS2 on very first page of wizard (earlier by default it was AXIS), now when I hit Next button, I am getting following error message,

Unable to add the follwing facets to project testWebProject: Axis2 Web Services Core, Axis2 Web Services Extensions.
org.eclipse.wst.common.project.facet.core.FacetedProjectFrameworkException: Failed while installing Axis2 Web Services Core 1.1.
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.callDelegate(FacetedProject.java:1497)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modifyInternal(FacetedProject.java:438)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChangesInternal(FacetedProject.java:1171)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.access$2(FacetedProject.java:1107)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject$1.run(FacetedProject.java:321)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1800)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modify(FacetedProject.java:336)
at org.eclipse.jst.ws.internal.consumption.ui.common.FacetOperationDelegate$1.run(FacetOperationDelegate.java:62)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: org.eclipse.core.runtime.CoreException: The Axis2 facets cannot be installed since the Axis2 runtime location has not been set.
Go to the Web Services preference page and set the Axis2 runtime location under Axis2 Preferences.
at org.eclipse.jst.ws.axis2.facet.deligate.Axis2CoreFacetInstallDelegate.execute(Axis2CoreFacetInstallDelegate.java:50)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.callDelegate(FacetedProject.java:1467)
... 8 more
Caused by: java.io.FileNotFoundException: \webapp (The system cannot find the file specified)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(Unknown Source)
at org.eclipse.jst.ws.axis2.core.utils.FileUtils.copy(FileUtils.java:158)
at org.eclipse.jst.ws.axis2.core.utils.FileUtils.copyDirectory(FileUtils.java:151)
at org.eclipse.jst.ws.axis2.facet.utils.Axis2WebappUtils.copyAxis2War(Axis2WebappUtils.java:94)
at org.eclipse.jst.ws.axis2.facet.commands.Axis2WebservicesServerCommand.executeOverride(Axis2WebservicesServerCommand.java:84)
at org.eclipse.jst.ws.axis2.facet.deligate.Axis2CoreFacetInstallDelegate.execute(Axis2CoreFacetInstallDelegate.java:43)
... 9 more


Any suggestion?


thnx....
 
Deepika Joshi
Ranch Hand
Posts: 268
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Solved above problem by
- downloading AXIS2
- Unzip & providing reference of AXIS2 into Eclipse
(Eclipse - Windows - Preferences - Axis2 - Axis2 runtime location (browse & refer Axis2 dir here)...


Lets see if it works...

 
Deepika Joshi
Ranch Hand
Posts: 268
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to create Aixs2-1.5 web service with Eclipse 3.4 IDE & App server is JBoss 4.2

I am able to use 'Web Service' wizard without getting any problem,

But When I am trying to create 'Web Service Client', I am not able to see (browse) Web service.

on following link http://localhost:8080/testWeb/axis2-web/, (testWeb is name of web application), I have following links

Services
Validate
Administration


But when I click Service link, I am getting the following error message;

13:11:02,562 INFO [STDOUT] [INFO] Clustering has been disabled
13:11:03,234 INFO [STDOUT] [INFO] Deploying module: addressing-1.5 - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/modules/addressing-1.5.mar
13:11:03,265 INFO [STDOUT] [INFO] Deploying module: metadataExchange-1.5 - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/modules/mex-1.5.mar
13:11:03,281 INFO [STDOUT] [INFO] Deploying module: mtompolicy-1.5 - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/modules/mtompolicy-1.5.mar
13:11:03,296 INFO [STDOUT] [INFO] Deploying module: ping-1.5 - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/modules/ping-1.5.mar
13:11:03,312 INFO [STDOUT] [INFO] Deploying module: script-1.5 - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/modules/scripting-1.5.mar
13:11:03,328 INFO [STDOUT] [INFO] Deploying module: soapmonitor-1.5 - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/modules/soapmonitor-1.5.mar
13:11:03,390 INFO [STDOUT] [WARN] Exception extracting jars into temporary directory : java.io.FileNotFoundException: C:\jboss-4.2.2.GA\server\default\.\tmp\deploy\tmp13419testEE.ear-contents\testWeb-exp.war\WEB-INF (Access is denied) : switching to alternate class loading mechanism
13:11:03,390 INFO [STDOUT] [INFO] Deploying Exception Occured with java.io.FileNotFoundException: C:\jboss-4.2.2.GA\server\default\.\tmp\deploy\tmp13419testEE.ear-contents\testWeb-exp.war\WEB-INF (Access is denied)
java.lang.RuntimeException: java.io.FileNotFoundException: C:\jboss-4.2.2.GA\server\default\.\tmp\deploy\tmp13419testEE.ear-contents\testWeb-exp.war\WEB-INF (Access is denied)
at org.apache.axis2.deployment.util.Utils.findLibJars(Utils.java:829)
at org.apache.axis2.deployment.util.Utils.createClassLoader(Utils.java:882)
at org.apache.axis2.jaxws.framework.JAXWSDeployer.deployServicesInWARClassPath(JAXWSDeployer.java:100)
at org.apache.axis2.jaxws.framework.JAXWSDeployer.init(JAXWSDeployer.java:80)
at org.apache.axis2.deployment.DeploymentEngine.initializeDeployers(DeploymentEngine.java:993)
at org.apache.axis2.deployment.DeploymentEngine.setConfigContext(DeploymentEngine.java:985)
at org.apache.axis2.deployment.WarBasedAxisConfigurator.setConfigContext(WarBasedAxisConfigurator.java:350)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:89)
at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:525)
at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:443)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:806)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
at java.lang.Thread.run(Thread.java:595)
Caused by: java.io.FileNotFoundException: C:\jboss-4.2.2.GA\server\default\.\tmp\deploy\tmp13419testEE.ear-contents\testWeb-exp.war\WEB-INF (Access is denied)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at org.jboss.net.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:105)
at java.net.URL.openStream(URL.java:1007)
at org.apache.axis2.deployment.util.Utils.findLibJars(Utils.java:811)
... 24 more
13:11:03,578 INFO [STDOUT] [INFO] Deploying Web service: testClass - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/services/testClass/
13:11:03,593 INFO [STDOUT] [INFO] Deploying Web service: version.aar - file:/C:/jboss-4.2.2.GA/server/default/./tmp/deploy/tmp13419testEE.ear-contents/testWeb-exp.war/WEB-INF/services/version.aar
13:11:03,593 ERROR [[/testWeb]] StandardWrapper.Throwable
java.lang.NoClassDefFoundError: org/apache/http/HttpResponseFactory
at org.apache.axis2.transport.http.SimpleHTTPServer.init(SimpleHTTPServer.java:116)
at org.apache.axis2.engine.ListenerManager.init(ListenerManager.java:74)
at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:449)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:806)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
at java.lang.Thread.run(Thread.java:595)
13:11:03,593 ERROR [[AxisServlet]] Allocate exception for servlet AxisServlet
java.lang.NoClassDefFoundError: org/apache/http/HttpResponseFactory
at org.apache.axis2.transport.http.SimpleHTTPServer.init(SimpleHTTPServer.java:116)
at org.apache.axis2.engine.ListenerManager.init(ListenerManager.java:74)
at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:449)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:806)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
at java.lang.Thread.run(Thread.java:595)




Please let me know if you have any suggestions.
thnx.....
 
Deepika Joshi
Ranch Hand
Posts: 268
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Trying to build Eclipse 3.4 + Axis2-1.5 + JBoss 4.2.2

I am able to fix fileNotFound error for org.apache.axis2.deployment.util.Utils files by placing axis2-1.2.jar file in lib folder,

but now I am getting following error when I hit Services link,

18:57:43,718 INFO [STDOUT] [ERROR] The following handler exists is not valid: phase rule has not been specified
org.apache.axis2.deployment.DeploymentException: The following handler exists is not valid: phase rule has not been specified
at org.apache.axis2.deployment.DescriptionBuilder.processHandler(DescriptionBuilder.java:415)
at org.apache.axis2.deployment.AxisConfigBuilder.processPhaseList(AxisConfigBuilder.java:387)
at org.apache.axis2.deployment.AxisConfigBuilder.processPhaseOrders(AxisConfigBuilder.java:418)
at org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:130)
at org.apache.axis2.deployment.DeploymentEngine.populateAxisConfiguration(DeploymentEngine.java:640)
at org.apache.axis2.deployment.WarBasedAxisConfigurator.<init>(WarBasedAxisConfigurator.java:136)
at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:486)
at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:406)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:806)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
at java.lang.Thread.run(Thread.java:595)
18:57:43,734 INFO [STDOUT] [ERROR] java.lang.NullPointerException: loading repository from classpath
18:57:43,734 ERROR [[AxisServlet]] Allocate exception for servlet AxisServlet
org.apache.axis2.deployment.DeploymentException: The "Dispatch" phase is not found on the global "InFlow" phase of the axis2.xml file. Make sure the phase is within the axis2.xml file.
at org.apache.axis2.deployment.util.PhasesInfo.getGlobalInflow(PhasesInfo.java:111)
at org.apache.axis2.engine.AxisConfiguration.validateSystemPredefinedPhases(AxisConfiguration.java:1022)
at org.apache.axis2.deployment.DeploymentEngine.loadFromClassPath(DeploymentEngine.java:150)
at org.apache.axis2.deployment.WarBasedAxisConfigurator.getAxisConfiguration(WarBasedAxisConfigurator.java:225)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:60)
at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:486)
at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:406)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:806)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
at java.lang.Thread.run(Thread.java:595)


Any suggestions?

Thanks....
 
Deepika Joshi
Ranch Hand
Posts: 268
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I used axis2-1.3 instead of axis2-1.5;
and its working... if you are new to Axis + Eclipse combination.... prefer to use axis2-1.3...

all the best...


going to try client generation....
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Thanks it helped me !!

one small correction - refer Axis2 runtime with in Eclipse - Windows - Preferences - web services - Axis2 - Axis2 runtime location

I used version 1.6.1 which is latest

- Kumar
 
Bartender
Posts: 4101
64
Hibernate Fedora Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Shouvanik Haldar,
Your post was moved to a new topic.
Split the post as it seems different from OP
 
Put the moon back where you found it! We need it for tides and poetry and stuff. Like this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!