• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Problem decrypting the encryptedKey at server side

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Hi,

Just a bit of background about my environment and problem: I am using JBoss 4.2.3 and JBoss metro for my web services. I am trying to test my web service with security using SOAtest6.2. I also have a servlet based client for my web service. I have enfored WS-Security policy using WSIT. Now when i use servlet based client everything works perfectly ok, however when i use SOAtest6.2 using the same keystore and truststore (which i have used for servlet based client) it doesn't seem to be working. I am getting the following error at server side:

ERROR [com.sun.xml.wss.logging.impl.opt.crypto] WSS1913: Key used to decrypt EncryptedKey cannot be null
ERROR [com.sun.xml.wss.logging.impl.opt.crypto] WSS1927: Error occured while decrypting EncryptedKey


I don't know where things are going wrong here.

Not sure what other information i should provide at the moment, however i will provide any information as and when required.

Thanks
reply
    Bookmark Topic Watch Topic
  • New Topic