Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

"Missing message for key" error!

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all!

I'm making some changes to a web application that uses an ApplicationResources.properties file and "<bean:message ..." tag to take labels from it.
I only need to add a label on a jsp page where other labels are used.

I added a key-value pair in the .properties file:

The second line is mine, the first one was there before.
And then I used, of course, the struts tag:

If I use only the first one, it works fine, but when I add my label, it causes a "Missing message for key" error.

I really don't understand. Same .properties file, same syntax and I'm sure that I wrote the keys consinstently... where am I falling?!

Thank you all.
Dolfiz
 
Dolfino Proteus
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Blame on me...

I'm developing on Eclipse and I switched off the auto-build feature... obviously every change I made was ignored by the application server that was deploying every time the same sources

Have a nice day all!
Dolfiz
 
Consider Paul's rocket mass heater.
    Bookmark Topic Watch Topic
  • New Topic