Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Jj Roberts
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Himai Minh
  • Carey Brown
  • salvin francis

Spanish charset problem in Jboss in linux

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Report post to moderator
hi,
I am having a problem with Spanish characters. My app server is jboss, os is linux and the charset iam using is UTF-8.
Iam using struts framework. All my java classes are compiled in UTF-8.
I have a form where i have to post some spanish data for e.g: Lácteos is a word in the post data.
I receive it as a request parameter in action class. When i print it in action class the accented character in the word turns into some strange character. which in turn messes up the rest of the code flow.
I am not having this problem in windows , its only in my dev environment which is linux.
I have to find a solution to this before i have to move it to QA or push alive.

I have tried a coupe of steps:-
I am forcing the java encoding to be UTF-8 in the java action files
All the Jsps are in UTF encoding.
During form post , I have forced form to accept UTF-8 encoding, but that didn’t work too


Please let me know if any of you have experienced such issues.

Thanks
Viiveek
 
Sheriff
Posts: 9674
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Report post to moderator
Duplicate Topic
 
    Bookmark Topic Watch Topic
  • New Topic