Win a copy of Mastering Corda: Blockchain for Java Developers this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Jj Roberts
  • Carey Brown
Bartenders:
  • salvin francis
  • Frits Walraven
  • Piet Souris

Running JBoss 5.1.0 All Server

 
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I downloaded the JBOSS 5.1.0 GA server zip and tried to run the server (all). In my server log i am getting the below given error message



also my boot.log is


After this i tried running the default server and got the following log



default server.log



The server.log is as given below




both of them shows some error because of Transaction Manager configuration. I am not able to figure whats the issue is all about ???



Thanks in advance.

Saikiran
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
One of the ways to almost guarantee that your post will not be answered is to overwhelm the readers with a ton of detail. Do you think that any of us are going to read all the stuff you posted? I sure am not. The only thing I looked at is the firs ERROR entry in the first log you posted, and I ignored everything else. Besides, Firefox complains that the scripts running on this page are becoming unresponsive due to the vast amounts of code you posted.

Anyway, the best way to track down an error is to follow the "caused by" links of the exception stack trace. Here is the root cause:

Caused by: java.lang.IllegalArgumentException: No such property transactionStatusManagerPort for bean com.arjuna.ats.jbossatx.jta.TransactionManagerService

I searched for "transactionStatusManagerPort, and even looked in the server/all/conf/jbossts-properties.xml where transaction properties are defined and could not find it. So what did you change or where did you set this port property?

 
Saikiran Madhavan
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Peter.

Sorry. I did a copy paste in a hurry...I am not able to remove the post as well.

As for as your question is concerned. I too checked the property it is trying to set but didnt find it. also i am new to JBoss 5.1.0 GA. You have mentioned something about jbossts-properties.xml. I am not aware of this xml configuration.

Also when i run the same thing in default server - in the server log i am getting a different exception stack trace



i found this property in the server/default/deploy/transaction-jboss-beans.xml but i am not sure what to set and how its working. also i found socketProcessIdPort in com.arjuna.ats.jbossatx.jta.TransactionManagerService bean in the bean definition file C:\jboss-5.1.0.GA\server\default\deploy\transaction-jboss-beans.xml. The value of this property is set as 0 and i just changed it into some number. But nothing changed because of that.

Any clue why i am getting this error, and is it because of the JbossTS configuration?

Thanks
Saikiran
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic