Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Cannot generate classes after inserting Struts stuff

 
Ranch Hand
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
my app was generating class files alright until i was
in EJB tier development.
When i got to WEB tier, i decided to go with Struts.
Created a couple JSPs, ActionForms and Actions
(without modifying EJBs) and run it. Everything is ok
till that point.
Then, i came back to EJB development again and for the
first time a tried to generate classes after including
Struts stuff in project, i got the following message
from my xdoclet generation.
ejbdoclet:
[ejbdoclet] BUILD FAILED: org.apache.commons.logging.LogConfigurationException:
java.lang.ClassNotFoundException:
org.easystruts.struts.config.EasyStrutsLogFactory

I took a look at xdoclet.xml file and saw this piece
of commented code.

I don't have any struts generated form by EJBs (i
generate them with EasyStruts).
I don't know what is going on, can anyone help me
here???
Thanks,
ltcmelo
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
how did you do it?

I am having same problem

please reply fast
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone.

Here's a little recipe that worked for me (I'm using Eclipse 2.1.3, Lomboz 213 and EasyStruts 0.70RC1, but it should work well with other versions)

1. Just in case, comment <strutsform /> in <EJB_MODULE>/META-INF/xdoclet.xml

2. In the same file, look for <fileset dir="${eclipse.home}/plugins">

3. After <include name="**/com.objectlearn.*/**/jakarta/*.jar"/> add the line <include name="**/com.cross.easystruts.*/**/*.jar"/>

This should add the easystruts.jar file to the classpath and prevent the EasyStrutsLogFactory error, 'cause the "missing" class is in that jar.

Good Luck!!!
 
Ranch Hand
Posts: 190
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry for digging up a probably dead thread, but I encountered the same problem and I discovered that it was due to my malformed struts-config.xml ! An <action> tag had a missing </action>.

Just like to add my 2-cents worth.

Thanks,
Ken
 
Let's go to the waterfront with this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic