• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Error 404 running JSP

 
Ranch Hand
Posts: 129
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ok guys I finally ran the server with eclipse . But I'm getting an error 404 every time I try running my JSP page. I checked and the project folder is inside C:\apache-tomcat-6.0.18\webapps . on http://localhost/manager/html Tomcat Web Application Manager the project is there but it says running = false . What else can I do ?
 
Author and all-around good cowpoke
Posts: 13078
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
If the management app says running = false, I would suspect that initialization of that web app failed and I would examine the logs.

What is the exact directory structure you have created?

What is the exact URL you are using to address the JSP page?

Bill
 
S Ali
Ranch Hand
Posts: 129
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You mean inside tomcat ?? C:\apache-tomcat-6.0.18\webapps\messages\index.jsp The project folder was moved automatically when I did add project in eclipse.
I tried also to export the project as WAR file and deploy it manually and I had the same problem also.


URL --> http://localhost/messages/index.jsp
This is from the logs


2010-02-18 2:32:54.PD org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:messages' did not find a matching property.
2010-02-18 2:32:54.PD org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Java\jdk1.6.0\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:/Program Files/Java1/jre1.6.0/bin/client;C:/Program Files/Java1/jre1.6.0/bin;D:\Oracle\app\oracle\product\10.2.0\server\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;D:\DB2\BIN;D:\DB2\FUNCTION;D:\DB2\SAMPLES\REPL;C:\Java\jdk1.6.0\bin;?
2010-02-18 2:32:54.PD org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-80
2010-02-18 2:32:54.PD org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 751 ms
2010-02-18 2:32:54.PD org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
2010-02-18 2:32:54.PD org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
2010-02-18 2:32:55.PD org.apache.catalina.core.ApplicationContext log
INFO: Initializing Spring root WebApplicationContext

 
Hey, sticks and stones baby. And maybe a wee mention of my stuff:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic