This week's book giveaway is in the Server-Side JavaScript and NodeJS forum.
We're giving away four copies of Node.js Design Patterns: Design and implement production-grade Node.js applications using proven patterns and techniques and have Mario Casciaro & Luciano Mammino on-line!
See this thread for details.
Win a copy of Node.js Design Patterns: Design and implement production-grade Node.js applications using proven patterns and techniques this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

strutstestcase and WSAD

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

I'm having problems runnings test cases built using strutstest case in WSAD 5.0.

Heres what I've done so far...

1.) Added the strutstestcase.jar file to my classpath (Java Build path in WSAD)

2.) addedd cactus related jar (Cactus.jar, Aspectjrt.jar, commons-httpclient,commons-logging, junit) to my class path (Same Java build location in WSAD)

3.) Changed the web.xml file in my struts application to include

servlet redirector, servlettestrunner

4.) copied the CactusTestLoginAction.java from struts distribution, altered it as per my requiremnets and ran the class in the container

by giving

http://localhost:9080/ServletTestRunner?suite=CactusTestLoginAction

Now I get some weird error

NoClassDefFoundError: org/apache/struts/action/ActionServlet

I've tried my struts application without this stuff and its working perfectly.

I check the web.xml for for any incorrect tags but evrythings just fine.

Can anyone please help me with this issue.

I know the error is not with web.xml but its with class loaders.

Oh and I forgot to mention i addedd the cactus.properties file too in the WEB-INF folder

Thanks in advance,
kiran
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic