• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

The Java Virtual Machine has exited with a code of 1, the service is being stopped.

 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I installed JDK1.3, I set the environment variable as JAVA_HOME set the jdk path,
then I installed Tomcat 4 on my machine,

i m tryin to start it from cmd,
it automatically stoped

when i view my event viewer i get

"The Java Virtual Machine has exited with a code of 1, the service is being stopped."

Please help me




 
Author and all-around good cowpoke
Posts: 13078
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
JDK 1.3 is so out of date that I can't imagine how you ended up using it. Likewise Tomcat 4.

Is there some reason you can't use the latest versions of Java and Tomcat?

Bill


 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
ya i know it is outdated

but what can be the solution to the problem

i mean if i m putting jdk 6 & Tomcat 6

still it is ginving same stuff

i m so fustrated, need solution

my final project is pending 'couse of this

thaks nayways

 
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Swati Save wrote:i mean if i m putting jdk 6 & Tomcat 6
still it is ginving same stuff



What kind of stuff are you getting? Check http://faq.javaranch.com/java/TellTheDetails
 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
i m tryin to start Tomcat 4 from cmd,
it automatically stoped

it is not givin anything on cmd

when i view my event viewer i get

"The Java Virtual Machine has exited with a code of 1, the service is being stopped."

I dont have IIS installed.
& only one jdk installed.

Thanks
Swati

 
Misha Ver
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Swati, you you want help, you have to provide details. How exactly do you start Tomcat? Have you checked Tomcat log files?
 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hello

start>run>cmd

on cmd

C:\>cd "Tomcat 4.1"
C:\Tomcat 4.1>cd bin
C:\Tomcat 4.1\bin>startup.bat
Using CATALINA_BASE: ..
Using CATALINA_HOME: ..
Using CATALINA_TMPDIR: ..\temp
Using JAVA_HOME: C:\jdk1.3
C:\Tomcat 4.1\bin>

another dos window must appear
it appears and quickly disaperars

i did't chk the Tomcat log file
from where can i chk that?

thanks,
Swati

 
Sheriff
Posts: 67749
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Swati Save wrote:
i did't chk the Tomcat log file
from where can i chk that?



did't? chk? Please read this: UseRealWords.
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Swati,

If you have the option of using the latest version of Java and Tomcat, then i would recommend that you start using those. I know you mentioned that you run into same issues with those versions. But let's use the latest versions and try and figure out what the problem is.

 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Sorry for earlier

I will again try with earlier versions

Thanks
 
Misha Ver
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Swati Save wrote:
C:\>cd "Tomcat 4.1"
C:\Tomcat 4.1>cd bin
C:\Tomcat 4.1\bin>startup.bat
Using CATALINA_BASE: ..
Using CATALINA_HOME: ..
Using CATALINA_TMPDIR: ..\temp
Using JAVA_HOME: C:\jdk1.3



I see the output after you have tried to run startup.bat, but you said before "it is not givin anything on cmd". Which one of your statements is correct?

How do you install Tomcat on you system?
 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
sir,

second dos window must appear showing tomcat is started

thats not happening

it appears and quickly disaperars

i am trying with new versions anyways

Thanks
 
Ranch Hand
Posts: 258
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Swati,

I think its because you have not added the environment variables for java and tomcat in my computer->properties. Also add the java classpath in path.
Other thing is start the command prompt separately. Don't just double click on startup.bat file so that you can see the actual error and we can help you out with that.

Doing these 3-4 things i think your issue must get resolved.
 
William Brogden
Author and all-around good cowpoke
Posts: 13078
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
OK - the window that shows and disappears has the error message you need to see.

In startup.bat the line that opens that window is:


change it to use run instead of start


Now the next bat file will run in the same command prompt window and you can see what actually happens.

(they really should put that hint in startup.bat)
Bill
 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey you guys thank you very much

Because of your guidance problem is solved

that run thing worked

the Exception was

java.net.BindException: Address already in use: JVM_Bind:8080

i just change the port from

Tomcat_install/conf/server.xml

file

now it is working fine

thank you very much
 
vijay jamadade
Ranch Hand
Posts: 258
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Swati,

Its good that problem resolved.

But there was no need to change port number. Just go to the task manager and kill all javaw.exe in process list because these processes uses that port. If you dont stop the tomcat manually the port gets busy. And if you again try to restart it gives the exception you have specified.

 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks man,

i did try that. their was no process like that.

i am happy that i now i can work on my project ay my place.

class Machine Room Sucks !

Swati Save
 
Rancher
Posts: 425
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Swati Save wrote:i did try that. their was no process like that.


You can check which process is occupying the port 8080 as follows:
1. Run command netstat -ano in command prompt.
2. Note the PID of the process occupying port 8080.
3. Start Windows task manager and check the noted PID for the process name.
4. Then you can kill the process if you wish to run Tomcat on 8080.
 
Swati Save
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey thanks
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic