Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
    Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Springs tiles issue

 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Report post to moderator
Hi everyone,
I'm new to springs and I'm trying to execute sample web application with tiles.these are the jars i used

antlr-runtime-3.0.jar
commons-beanutils-1.7.0.jar
commons-digester-1.8.jar
commons-logging-1.0.4.jar
commons-logging-api-1.1.jar
jstl.jar

org.springframework.aop-3.0.1.RELEASE-A.jar
org.springframework.asm-3.0.1.RELEASE-A.jar
org.springframework.aspects-3.0.1.RELEASE-A.jar
org.springframework.beans-3.0.1.RELEASE-A.jar
org.springframework.context.support-3.0.1.RELEASE-A.jar
org.springframework.context-3.0.1.RELEASE-A.jar
org.springframework.core-3.0.1.RELEASE-A.jar
org.springframework.expression-3.0.1.RELEASE-A.jar
"WebContent/"WebContent/WEB-INF/lib/org.springframework.instrument-3.0.1.RELEASE-A.jar
"WEB-INF/lib/org.springframework.instrument.tomcat-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.jdbc-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.jms-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.orm-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.oxm-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.transaction-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.web.portlet-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.test-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.web.servlet-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.web.struts-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/org.springframework.web-3.0.1.RELEASE-A.jar"
"WebContent/WEB-INF/lib/servlet-api.jar"
"WebContent/WEB-INF/lib/slf4j-api-1.5.8.jar"
"WebContent/WEB-INF/lib/slf4j-jdk14-1.5.8.jar"
"WebContent/WEB-INF/lib/standard.jar"
"WebContent/WEB-INF/lib/tiles-api-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-compat-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-core-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-extras-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-el-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-freemarker-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-jsp-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-ognl-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-mvel-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-portlet-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-servlet-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-servlet-wildcard-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-test-alt-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-template-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-test-db-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-test-common-2.2.1.jar"
"WebContent/WEB-INF/lib/tiles-velocity-2.2.1.jar"
"WebContent/WEB-INF/lib/velocity-1.6.2.jar"
"WebContent/WEB-INF/lib/velocity-tools-2.0-20090514.211946-1.jar"
jcl-over-slf4j-1.5.8.jar


My servlet mapping xml is
<?xml version="1.0" encoding="UTF-8"?>

<beans xmlns="http://www.springframework.org/schema/beans"; xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
xmlns:p="http://www.springframework.org/schema/p";
xmlns:context="http://www.springframework.org/schema/context";
xsi:schemaLocation="
http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd
http://www.springframework.org/schema/context
http://www.springframework.org/schema/context/spring-context.xsd">;

<!-- the application context definition for the springapp DispatcherServlet -->

<bean name="/welcome.htm" class="com.tea.controllers.WelComeController"/>
<!-- <bean id="viewResolver" class="org.springframework.web.servlet.view.ResourceBundleViewResolver" p:basename="views" />
<context:component-scan base-package="com.tea.controller" /> -->
<!--<bean id="viewResolver" class="org.springframework.web.servlet.view.ResourceBundleViewResolver">
<property name="basename">
<value>views</value>
</property>
</bean>
-->

<bean id="tilesConfigurer" class="org.springframework.web.servlet.view.tiles2.TilesConfigurer" p:definitions="/WEB-INF/tiles-defs.xml" />
<bean id="tilesViewResolver"
class="org.springframework.web.servlet.view.UrlBasedViewResolver"
p:viewClass="org.springframework.web.servlet.view.tiles2.TilesView" />

</beans>

my tiles def xml is
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE tiles-definitions PUBLIC "-//Apache Software Foundation//DTD
Tiles Configuration 2.0//EN" "http://tiles.apache.org/dtds/tiles-config_2_0.dtd">;

<tiles-definitions>
<definition name="baseLayout" template="/views/skeletonHome.jsp">
<put-attribute name="title" value="Template"/>
<put-attribute name="header" value="/views/Header.jsp"/>
<put-attribute name="left" value="/views/Highlights.jsp"/>
<put-attribute name="right" value="/views/FundsClientsStatus.jsp"/>
<put-attribute name="footer" value="/views/SystemActLog.jsp"/>
</definition>
<definition name="baseLayout1" template="/views/skeletonHome.jsp">
<put-attribute name="header" value="/views/Header.jsp"/>
<put-attribute name="left" value="/views/Highlights.jsp"/>
<put-attribute name="footer" value="/views/SystemActLog.jsp"/>
</definition>
<definition name="welcome" extends="baseLayout">
<put-attribute name="title" value="Welcome"/>
<put-attribute name="left" value="/views/Highlights.jsp"/>
<put-attribute name="right" value="/views/FundsClientsStatus.jsp"/>
</definition>
</tiles-definitions>

If i run this application i'm getting excetion saying that

DispatcherSer E org.springframework.web.servlet.FrameworkServlet initServletBean Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'tilesConfigurer' defined in ServletContext resource [/WEB-INF/tea-servlet.xml]: Invocation of init method failed; nested exception is java.lang.NoSuchMethodError: org/apache/tiles/TilesApplicationContext.getContext()Ljava/lang/Object;
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1403)

please help me in this
thanks in advance

 
ranger
Posts: 17346
11
Mac IntelliJ IDE Spring
  • Mark post as helpful
  • send pies
  • Report post to moderator
Please don't resurrect old threads. This thread is about 2 years old. Typically the OP has moved on and might not ever see your post.

It is better to create a brand new thread for yourself.

Closing this thread.

Thanks for understanding

Mark
 
Mark Spritzler
ranger
Posts: 17346
11
Mac IntelliJ IDE Spring
  • Mark post as helpful
  • send pies
  • Report post to moderator
Abhinav Nigam,
Your post was moved to a https://coderanch.com:80/t/583753";" target="_new" rel="nofollow">new topic.
 
When all four tires fall off your canoe, how many tiny ads does it take to build a doghouse?
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic