• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Action Mapping not found- Please help

 
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am trying simple example from , Using WSAD 5.0

http://www.sourcebeat.com/docs/Jakarta%20Struts%20Live/Rev_2/Jakarta%20Struts%20Live_SampleChapter.pdf


struts-config.xml has mapping that dosn't work

<action path="/userRegistration" type="strutsTutorial.UserRegistrationAction">
<forward name="success" path="/pages/regSuccess.jsp" redirect="false" />
</action>

But this mapping works fine
<action path="/MYWelcome" type="org.apache.struts.actions.ForwardAction" parameter="/pages/regSuccess.jsp" />


UserRegistrationAction.java has method

public ActionForward execute(
ActionMapping mapping,
ActionForm form,
HttpServletRequest request,
HttpServletResponse response)
throws Exception {
log.trace("in execute method of UserRegistrationAction");
System.out.println("I am in UserRegistration ");
return mapping.findForward("success");
}


I don't see any trace log, or System.out

Console output is
8/31/04 9:59:33:047 PDT] 60c88c43 WebGroup I SRVE0180I: [Struts Blank Application] [/strutsTutorial] [Servlet.LOG]: action: Processing a GET for /userRegistration
[8/31/04 9:59:33:047 PDT] 60c88c43 WebGroup I SRVE0180I: [Struts Blank Application] [/strutsTutorial] [Servlet.LOG]: action: Looking for Action instance for class strutsTutorial.UserRegistrationAction
[8/31/04 9:59:33:047 PDT] 60c88c43 WebGroup I SRVE0180I: [Struts Blank Application] [/strutsTutorial] [Servlet.LOG]: action: Double checking for Action instance already there
[8/31/04 9:59:33:047 PDT] 60c88c43 WebGroup I SRVE0180I: [Struts Blank Application] [/strutsTutorial] [Servlet.LOG]: action: Creating new Action instance



I guess it is not finding UserRegistrationAction class.

Help from all of you is appreciated.

Thanks,
 
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Does your web.xml properly define the ActionServlet?
reply
    Bookmark Topic Watch Topic
  • New Topic