• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Struts problem with InsertTag

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm having an issue with websphere 5.1 and tiles not rendering correctly with large amounts of data. Somehow the data seems to be interrupted randomly and doesn't produce the full html that I'm expecting. To me it sounds like a problem with buffers and flushing and eventually I found a workaround.
I makde a change in method doEndTag of InsertTag from this:

// include requested component.
if (flush) {
pageContext.getOut().flush();
}
doInclude(page);

to this:

if (flush) {
pageContext.include(page);
} else {
TilesUtil.doInclude( page, (HttpServletRequest)pageContext.getRequest(),(HttpServletResponse)pageContext.getResponse(),pageContext.getServletContext());
}

Is this purely a Websphere issue or is anyone else experiencing similar problems with uncomplete data?

/C a Struts newbie
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic