Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

java.lang.reflect.InvocationTargetException Caused by: java.lang.UnsatisfiedLinkError

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm using jdic web browser (windows version) and customizing it for a project. I want to make an executable jar file. Since I'm using NetBeans 6.7.1, I'm getting a jar file in dist folder. Bt when I run it it does not open the jdic browser.

Then I tried java web start and make a jnlp file. When it tries to run I get the below error..

java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Launcher.java:1293)
at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1239)
at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1086)
at com.sun.javaws.Launcher.run(Launcher.java:105)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: no jdic in java.library.path
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at org.jdesktop.jdic.browser.internal.WebBrowserUtil$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at org.jdesktop.jdic.browser.internal.WebBrowserUtil.loadLibrary(Unknown Source)
at org.jdesktop.jdic.browser.internal.WebBrowserUtil.getDefaultBrowserPath(Unknown Source)
at org.jdesktop.jdic.browser.BrowserEngineManager.selectEngine(Unknown Source)
at org.jdesktop.jdic.browser.BrowserEngineManager.getActiveEngine(Unknown Source)
at AgentBrowser.Browser.jbInit(Browser.java:362)
at AgentBrowser.Browser.<init>(Browser.java:99)
at AgentBrowser.Browser.main(Browser.java:117)
... 9 more

http://java.ittoolbox.com/groups/technical-functional/javaee-l/how-to-resolve-the-errorjavalangreflectinvocationtargetexception-1710507
A person shared his view on "java.lang.reflect.InvocationTargetException" but I'm not quite sure about that since the browser works nicely if I run through NetBeans. (running the project through NetBeans).

I dnt know how does this library path problem occurs

please help me..!!

thanks in advance
 
Shashika Wickramarachchi
Greenhorn
Posts: 5
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah..! it's working

I just copied jdic files (jdic.jar,jdic.dll, IeEmbed.exe etc) into dict/lib/ folder and now it is working.
 
Sheriff
Posts: 6632
1254
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic