• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • paul wheaton
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Tim Holloway
  • Carey Brown
  • salvin francis

Eclipes IDE "Password Required" popup

 
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I am in the Java editor, I hit the '.' to see an object's methods, and I am interfered with a popup, "Password Required, Connect to: java.sun.com, HTTP Authentication, User name: Password:".

This just started happening today: Anyone know what is going on? How do I stop this annoying popup?
 
Ranch Hand
Posts: 234
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

M Burke wrote:I am interfered with a popup, "Password Required, Connect to: java.sun.com, HTTP Authentication, User name: Password:".



Hi Burke,

Which version of Eclipse are you using? Because till Eclipse Galileo I never faced such issue?

 
Ranch Hand
Posts: 37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you please upload a screenshot.
 
M Burke
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The version is Galileo. It just started popping up yesterday
pwreq.jpg
[Thumbnail for pwreq.jpg]
Eclipes Popup
 
Pradeep Katipamula
Ranch Hand
Posts: 37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was asking for a screenshot to see what editor/perspective you are using. You've given a small cropped image, anyways I am sorry i was not clear too.
Are you working with xml stuff?
 
Fidel Edwards
Ranch Hand
Posts: 234
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

M Burke wrote:The version is Galileo. It just started popping up yesterday



Hi M Burke,

I think you are using the Maven if yes then you will get such kind of pop-ups.


 
M Burke
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Pradeep Katipamula wrote:I was asking for a screenshot to see what editor/perspective you are using. You've given a small cropped image, anyways I am sorry i was not clear too.
Are you working with xml stuff?



I am in the Java perspective, although it happends in any perspective with a Java editor. What I am doing is 'Code Completion', the password popup interfers with this dropdown.


I am not using Maven, but I do get these popups when I use Hibernate.
codecompletion.jpg
[Thumbnail for codecompletion.jpg]
 
Greenhorn
Posts: 1
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem here is eclipse tries to connect to remote site in some cases - validating the xsd/namespaces etc.

If you are behind a proxy server that requires authentication, type in the credentials.

You may also tweak the Eclipse proxy settings, Window-> Preferences ->Network connections.

It should work fine.
 
Fidel Edwards
Ranch Hand
Posts: 234
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Gaurav,

Welcome to JavaRanch. Good to see that your first post come up with solution
 
Greenhorn
Posts: 17
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Go to Windows --> Preference --> Network Connections and set Active Provider as "Direct".
This solved the problem for me in Eclipse Indigo.
 
Ranch Hand
Posts: 34
1
MyEclipse IDE Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
how can i resolve this in Eclipse Java EE IDE for Web Developers because this path (Go to Windows --> Preference --> Network Connections and set Active Provider as "Direct".
) does exist in this version . And message prompt every time to enter user id and passwordwhen i focus on editor
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
To disable, go to Window-Preferences-Java-Installed JRE - select your current JRE - Edit - Select rt.jar - Java doc location - Delete java doc location path
 
Ravi Shankar Kumar
Ranch Hand
Posts: 34
1
MyEclipse IDE Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This did not worked for me . Unchecked the reference of install/update for available software site stoped asking frequently for the userid/password. but in start it ask for once .
 
Ravi Shankar Kumar
Ranch Hand
Posts: 34
1
MyEclipse IDE Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

Finally I got the solution of this problem . Now I am able to work smoothly without any disturbance of this credential Prompt in Eclipse Java EE IDE for Web Developers [Version: Helios Service Release 2]. I tried many thing But the Actual solution is below .
1. Go to Window Menu -> Preference
2. select General->Network Option
3. This page will have active provider as Manual in drop down .
4. Change It to Direct
5. Apply the changes and Enjoy

Also look into the screen shot here for help .
Eclipse-solution.png
[Thumbnail for Eclipse-solution.png]
Screen Shot of page where change need to be done
 
Story like this gets better after being told a few times. Or maybe it's just a tiny ad:
professionally read, modify and write PDF files from Java
https://products.aspose.com/pdf/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!