• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • paul wheaton
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Tim Holloway
  • Carey Brown
  • salvin francis

How I run my web application on browser after deploying it on Websphere Application Server 6

 
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What I am trying to do is deploying a struts blank application (struts2-blank-2.1.8.1.war downloaded directly from apache site) on IBM Websphere Application Server 6.0.

For this I created new application server and new HTTP server.

New Application Server Details:

WAS version :6.0.2.19
Application server name :IRISINFO_TEST1
Server description : IRISINFO_TEST1 for deploying IRISInfoSystem.war
Internal port range : 10048 - 10062
Virtual host : default_host
Profile root : /QIBM/UserData/WebSphere/AppServer/V6/Base/profiles
External HTTP server association : IRIS_HTTP
Server URL : http://IRISNEW:10002
Business applications : None
Sample applications :

Application name URL to access application

query Used by EJB client applications

Default Applications http://IRISNEW:10002/snoop
http://IRISNEW:10002/hitcount
http://IRISNEW:10002/hello

Note: To access the application(s) you have choosen, start both the application server and HTTP server, then enter a URL from the table above.

New HTTP Server Details:

HTTP server name : IRIS_HTTP
HTTP server description : HTTP server created by the Create Application Server wizard.
Port : 10002
Document root : /www/iris_http/htdocs
Server root : /www/iris_http
Current application server association :None
New application server association : IRISINFO_TEST1, V6.0


Both are in running mode. After that I tried running 3 default applications by using following URLs and they are running fine:

http://10.1.0.3:10002/snoop
http://10.1.0.3:10002/hitcount
http://10.1.0.3:10002/hello

Now when i deployed struts blank application, it get successfully deployed. I tried running this struts blank application using the following URL:

http://10.1.0.3:10002/struts2-blank-2.1.8.1

But it doesn't show the expected page. The Websphere console clearly shows that this struts blank application is successfully deployed but I am not able to run that.
I am using IBM WAS console on http://10.1.0.3:2001/HTTPAdmin

Can you please tell me how I can run my application?

Thanks
 
Ranch Hand
Posts: 446
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you check following things ?

1. While installing the application in WAS console you select both the WAS Server and the HTTP Server in the installation process. This will cause the updating of the plugin-config.xml file for the IHS Server.

2. Whats the web context URI for struts2-blank-2.1.8.1

3. Access the application going directly to WAS.

4. Access the application going via IHS.
 
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi this might be useful to you.
Go servers--->applicationservers--->click on your server----->click on ports(leftside)--->see w3cdefaulthost number.


now access the application using

http://<hostnma>:<w3defaulthost>/<contextroot>;
 
Good heavens! What have you done! Here, try to fix it with this tiny ad:
Enterprise-grade Excel API for Java
https://products.aspose.com/cells/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!