• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

new MQConnectionFactory throwing null pointer in jboss

 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am trying to execute the following command


and i get a null pointer that i can't seem to track down, i have attached the stack trace, any help would be greatly appreciated.
java.lang.NullPointerException
at com.ibm.msg.client.jms.internal.JmsFactoryFactoryImpl.getInstance(JmsFactoryFactoryImpl.java:169)
at com.ibm.msg.client.jms.admin.JmsConnectionFactoryImpl.setProviderFactory(JmsConnectionFactoryImpl.java:165)
at com.ibm.mq.jms.MQConnectionFactory.<init>(MQConnectionFactory.java:271)
at com.foundation.agent.plugin.JMSClient.createConnection(JMSClient.java:154)
at com.foundation.agent.plugin.JMSClient.launch(JMSClient.java:108)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)

i am loading the class that calls the new MQConectionFactory() using a class loader so i suspect that some jboss JMS lib possibly causing this.

more info:
com.ibm.mq.runtime_7.0.1.0\lib

jars
com.ibm.mq.headers.jar
com.ibm.mqjms.jar
jms.jar
com.ibm.mq.jar
connector.jar
jta.jar
com.ibm.mq.jmqi.jar
dhbcore.jar
providerutil.jar
com.ibm.mq.pcf.jar
fscontext.jar
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Are you sure this is JBoss related? Looks to me like you are using IBM's MQ Series.
 
Jesse Reim
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Yes i am certain it is a Jboss configuration issue. because if i wrap a connection test in a stand alone jar and run that from the command line it works however i get the null pointer when trying to run that within jboss...

I am looking into what is configured in the C:\jboss4\server\deploy\jms directory and possible contention there...

Im sorry for the double post i was not sure where it was most applicable ...

any assistance would be greatly appreciated
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

java.lang.NullPointerException
at com.ibm.msg.client.jms.internal.JmsFactoryFactoryImpl.getInstance(JmsFactoryFactoryImpl.java:169)



You'll have to find out what com.ibm.msg.client.jms.internal.JmsFactoryFactoryImpl is doing on line 169. That's where the NullPointerException is coming from.
 
Jesse Reim
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator




yeah i know that's where its coming from but that is a third party jar and the source is not available so i couldn't step through it, i have solved this issue and it was using a version of the MQ client 7.0.1.1 that was not compatable with jboss, so i switched to 6.0.2.9 and it is working now....
 
reply
    Bookmark Topic Watch Topic
  • New Topic