• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

MySQL DataSource error on WAS6

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello all!
please tell my what to do if I get such error after pushing "test connection" button in WAS 6.1.0.15:

When I make telnet from WAS server to my MySQL server - it works, I see reply in some binary signs...
But when I loaded tcpdump:3306 and pushed "test connection" there were no packets at all.
I recreated new source - it does'nt help.
I tried the same steps for creating data sourse on other server (WAS7) and it works

btw, i use mysql-connector-java-5.1.12-bin.jar driver
 
Ranch Hand
Posts: 198
Oracle Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You need to check with the connection parameters (url, user name, password, dsn etc.,) you are passing.
Most of the times we get the exception when connection parameters are not correct.

Try to make a simple jdbc connection from your java class. If that works.. pass on the same parameters in server configuration.
 
Sergey Borisov
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thankyou Prabhakar for your answer!

Ofcourse I cheked account parameters for my db, they are:
Data sources > MySQLDataSource > Custom properties:
port 3306
databaseName ecms
serverName 10.17.225.60



But how simple jdbc connection will work if it uses that data source configured in WAS which is not workin ?
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Sergey,
Check user and password properties.
it should be some thing like user=root password=somevalue
Cheers
Ramesh Thulasi
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic