• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Devaka Cooray
  • Ron McLeod
  • Jeanne Boyarsky
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Martijn Verburg
  • Frits Walraven
  • Himai Minh

Custom tld declaration and nested tiles...

 
Ranch Hand
Posts: 264
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm using a custom tag library with tiles and for some reason, when I declare the tag library in a template, and try to use the tags inside of tiles that get inserted into the template the tags don't get created (a quick look at the source of the html shows the tags are tehre just not getting interpetted). When I declare the tag library in each component jsp document it works.

All of the struts tlds work "across" tiles, is there something special I need to do get mine to work that way too?
 
pie sneak
Posts: 4727
Mac VI Editor Ruby
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Tad Dicks:

All of the struts tlds work "across" tiles, is there something special I need to do get mine to work that way too?



Each tile gets rendered independently. It was my understanding that not even struts tags could be declared in the template and implemented in the inner tiles.
 
Tad Dicks
Ranch Hand
Posts: 264
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Well they work... but maybe I've got it declared in a header.fragment and not a template. Wether or not the IDE picks up on the included tld seems hit or miss (at least with netbeans).
...
Ok, I do have them in a fragment jsp headerfile (in addition to the template, guess I should take them out of the template heh).


-Tad
 
If you send is by car it's a shipment, but if by ship it's cargo. This tiny ad told me:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic