Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Database Access works on a manually started Tomcat but not on a Tomcat started as a Service

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello JavaRanch People :-)

My problem is the following - i programmed an application which accesses a ms sql server through native authentification (jdbc driver is jtds). everything works fine in my development environment (eclipse) and also directly under tomcat - at least if i start up manually (of course i had to put the native dll file for single sign on in a directory where my java library path points to). BUT (!!!) it doesn't work if i start tomcat as a service!

I already found out where my library path is by adding


to my application which returns:

INFO:
C:\Program Files\apache-tomcat-6.0.26\bin;
.;
C:\Windows\Sun\Java\bin;
C:\Windows\system32;
C:\Windows;C:\Windows\system32;
C:\Windows;
C:\Windows\System32\Wbem;
C:\Windows\System32\WindowsPowerShell\v1.0\;
c:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;
c:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;
c:\Program Files\Microsoft SQL Server\100\Tools\Binn\;
c:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;

I already tried putting the .dll file ("ntlmauth.dll" shipped with the jdbc driver) in some of that places, but the application always throws the following exception:



... which means that the native library for using that driver was not found (SSO = Single Sign On -> needs "ntlmauth.dll" shipped with the jdbc driver). As I said: it works in eclipse or if I start tomcat manually, but it doesn't work if I start tomcat as a service. I also tried starting it as admin... any suggestions? I am sure more ppl are getting this error...

Thanks in advance for any useful tips! :-)
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic