• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Unable to login to the jboss console

 
Ranch Hand
Posts: 142
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have installed jboss-eap-4.3 and running the default server with JDK5.0_11.
Server starts without errors with the command run.sh -c default.

When I attempt to to view JBoss Web Console in http://localhost:9080/, it asks for password.
I tried admin/admin but it doesn't work.

Looked at the properties files in conf\props, and added a user user1/user1 in jmx-console-users.properties. And restarted the server.
I still can not login to the server.

Please help
 
Ranch Hand
Posts: 1179
Mac OS X Eclipse IDE
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
http://www.techienuggets.com/Detail?tx=9

5. While you are in directory make copies of the two jmx-console properties files and call them web-console-roles.properties
and web-console-users.prperties respectively.
6. The property files for web-console currently exist under \server\default\deploy\management\console-mgr.sar\web-console.war\WEB-INF\classes.
I would rename these files.
7. edit \server\default\conf\login-config.xml

<application-policy name = "web-console">
<authentication>
<login-module code="org.jboss.security.auth.spi.UsersRolesLoginModule"
flag = "required">
<module-option name="usersProperties">props/web-console-users.properties</module-option> <module-option name="rolesProperties">props/web-console-roles.properties</module-option> </login-module>
</authentication>
</application-policy

In the above you need to add the props/ because this is missing in the original file.

 
Jeevan Reddy
Ranch Hand
Posts: 142
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Larsen, Thanks a lot for the link.
It clearly explains how to enable security for jmx and web consoles, though I had intended to disable security altogether.
Instead I have enabled and I am able to login and view JMX and WEB consoles.

one clarification needed. In the link it is given that by default security is disabled. It doesn't appear like that with - jboss-eap-4.3

But my issue is resolved. Thanks a lot for the help
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Jeevan Reddy wrote:

one clarification needed. In the link it is given that by default security is disabled. It doesn't appear like that with - jboss-eap-4.3



The community versions of JBoss AS have the default security disabled. You are using EAP version (the enterprise paid version) for which security is enabled by default.
reply
    Bookmark Topic Watch Topic
  • New Topic