Win a copy of Terraform in Action this week in the Cloud forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Issue in Eclipse 3.5 Galileo (PermGen Space Error and Out of memory error)

 
sarvan kumar
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

I am facing an issue in Eclipse IDE when i create/ or work with new dynamic web prjoct.
Here i have metioned the issue in detail.

Error: "PermGen Space Error" , "Processing Dirty Regions", "Out of memory error"
Once this error raised, the Eclipse windows closed
Eclipse version: 3.4 Ganemede and also in 3.5 Gallilo
Operating Enviroment Windows XP


Waiting for your valuable suggestions to move forward.

Thanks and Regards,
K.Saravana Kumar
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Go into eclipse.ini and increase the value of the -XX:MaxPermSize setting and restart Eclipse. (I'm curious, though - in my eclipse.ini file MaxPermSize is set to 256M, what kind ofp roject do you have that it would overflow that?)
 
sarvan kumar
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
When i installing jboss softwares on eclipse-SR-32 Galileo i have faced an error as follows

"Install has encountered a problem.An error occured during the org.eclipse.equinox.internal.provisional.p2.engine.phases.CheckTrustphase"

can anyone having solution waiting for your valuable reply

Regards,
K.Saravana kumar
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
What JBoss softwares are you installing? JBoss Tools? And how are you doing this install? If via Eclipse update manager, the URL you gave to Eclipse would help.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic