• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Liutauras Vilda
  • Paul Clapham
Sheriffs:
  • paul wheaton
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Piet Souris
Bartenders:
  • Mike London

Error on deploy after adding Axis2 to a project

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am working on some web service client.

For this project I use:
Eclipse Galileo
Oracle AS (oc4j-10.1.3.5)
Axis2 (1.5.2.)

I find out that my problems starts right at the begining. At first I generate EAR project with EJB and WAR project. After quick generation of required workspace I deploy a "dummy" project to a server without a porblem.

Then I go to WAR project Properties -> Project Facets and check "Axis2 Web Services" which is a normal procedure if you look at tutorials that are on-line. After "apply" I get some stuff in WebContent/WEB-INF folder and WebContent/axis2-web folder.
Right after that procedure I try to deploy this "dummy" application to a AS and receive error:
BUILD FAILED
D:\OAS\eclipse\plugins\org.eclipse.jst.server.generic.oc4j_1.5.206.v20090812\buildfiles\oracle.10.1.3.xml:97: Deploy error: Operation failed with error:
Error instantiate servlet classes





Any help would be appreciated,
Dejan
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic