• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

WAS 7 Please specify a different location with -tracefile option.

 
Ranch Hand
Posts: 51
jQuery Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am testing my websphere configuration scripts. I am using was ant tasks and jacl scripts for configuration. While executing I am getting following error
configure-jdbc:
[wsadmin] Executing '/usr/jdk/instances/jdk1.5.0/jre/bin/java' with arguments:
[wsadmin] '-Dlocal.cell=ACESCell'
[wsadmin] '-Dlocal.node=ACESLABNode'
[wsadmin] '-Dcom.ibm.etools.EJBDeploy.debug=true'
[wsadmin] '-Dcom.ibm.itp.location=/websphere/AppServer/deploytool/itp'
[wsadmin] '-Dcom.ibm.CORBA.BootstrapHost=whpsacessa1.sunamerica.com'
[wsadmin] '-Dcom.ibm.ws.management.standalone=true'
[wsadmin] '-Dfile.encoding=UTF-8'
[wsadmin] '-Dconsole.encoding=UTF-8'
[wsadmin] '-Dosgi.install.area=/websphere/AppServer'
[wsadmin] '-Dosgi.configuration.area=/websphere/AppServer/profiles/configuration'
[wsadmin] '-Dcom.ibm.SSL.ConfigURL=file:/websphere/AppServer/profiles/properties/ssl.client.props'
[wsadmin] '-Dcom.ibm.CORBA.ConfigURL=file:/websphere/AppServer/profiles/properties/sas.client.props'
[wsadmin] '-Djava.security.auth.login.config=/websphere/AppServer/profiles/properties/wsjaas_client.conf'
[wsadmin] '-Dcom.ibm.SOAP.ConfigURL=file:/websphere/AppServer/profiles/properties/soap.client.props'
[wsadmin] '-Dwebsphere.lib.dir=/websphere/AppServerlib'
[wsadmin] '-Djava.util.logging.manager=com.ibm.ws.bootstrap.WsLogManager'
[wsadmin] '-Djava.util.logging.configureByServer=true'
[wsadmin] '-Dws.ext.dirs=/websphere/AppServer/java/lib:/websphere/AppServer/classes:/websphere/AppServer/lib:/websphere/App
Server/installedChannels:/websphere/AppServer/lib/ext:/websphere/AppServer/web/help:/websphere/AppServer/deploytool/itp/plugi
ns/com.ibm.etools.ejbdeploy/runtime'
[wsadmin] '-Dserver.root=/websphere/AppServer'
[wsadmin] '-Dwas.install.root=/websphere/AppServer'
[wsadmin] '-Duser.install.root=/websphere/AppServer/profiles'
[wsadmin] '-Dwas.node.name=ACESLABNode'
[wsadmin] '-Dwas.cell.name=ACESCell'
[wsadmin] '-Dwas.repository.root=/websphere/AppServer/profiles/config'
[wsadmin] '-Xmx256M'
[wsadmin] '-classpath'
[wsadmin] '/websphere/AppServer/profiles/properties:/websphere/AppServer/properties:/websphere/AppServer/lib/startup.jar:/w
ebsphere/AppServer/lib/bootstrap.jar:/websphere/AppServer/lib/lmproxy.jar:/websphere/AppServer/lib/urlprotocols.jar:/webspher
e/AppServer/java/lib/tools.jar:/websphere/AppServer/deploytool/itp/batchboot.jar:/websphere/AppServer/deploytool/itp/batch2.j
ar'
[wsadmin] 'com.ibm.wsspi.bootstrap.WSPreLauncher'
[wsadmin] '-nosplash'
[wsadmin] '-application'
[wsadmin] 'com.ibm.ws.bootstrap.WSLauncher'
[wsadmin] 'com.ibm.ws.admin.services.WsAdmin'
[wsadmin] '-f'
[wsadmin] '/centive/downloads/Centive_4.3.2.319/Workbench/4.3.2.319/app-server/config/websphere/JDBC/config_oracle_jdbc.jac
l'
[wsadmin] '-lang'
[wsadmin] 'jacl'
[wsadmin] '-conntype'
[wsadmin] 'SOAP'
[wsadmin] '-host'
[wsadmin] 'whpsacessa'
[wsadmin] '-port'
[wsadmin] '8880'
[wsadmin] '-user'
[wsadmin] 'wasadmin'
[wsadmin] '-password'
[wsadmin] '<was password>'
[wsadmin] 'ACESCell'
[wsadmin] 'ACESLABNode'
[wsadmin] 'server1'
[wsadmin] '<db sid>'
[wsadmin] '<db box name>'
[wsadmin] '1521'
[wsadmin] '<db user>'
[wsadmin] '<db password>'
[wsadmin] 'energizer'
[wsadmin] 'energizer'
[wsadmin] '0'
[wsadmin] '2'
[wsadmin] '/oracle/product/9.2.0/jdbc/lib/classes12.zip'
[wsadmin]
[wsadmin] The ' characters around the executable and arguments are
[wsadmin] not part of the command.
[wsadmin] !SESSION 2010-11-12 10:28:40.297 -----------------------------------------------
[wsadmin] eclipse.buildId=M20060921-0945
[wsadmin] java.version=1.5.0_16
[wsadmin] java.vendor=Sun Microsystems Inc.
[wsadmin] BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en_US
[wsadmin] Framework arguments: -application com.ibm.ws.bootstrap.WSLauncher
[wsadmin] Command-line arguments: -application com.ibm.ws.bootstrap.WSLauncher

[wsadmin] !ENTRY org.eclipse.osgi 4 0 2010-11-12 10:28:40.575
[wsadmin] !MESSAGE Error reading configuration: /websphere/AppServer/profiles/configuration/org.eclipse.osgi/.manager/.file
TableLock (Permission denied)
[wsadmin] !STACK 0
[wsadmin] java.io.FileNotFoundException: /websphere/AppServer/profiles/configuration/org.eclipse.osgi/.manager/.fileTableLo
ck (Permission denied)
[wsadmin] at java.io.RandomAccessFile.open(Native Method)
[wsadmin] at java.io.RandomAccessFile.<init>(RandomAccessFile.java:212)
[wsadmin] at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_JavaNio.java:30)
[wsadmin] at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.java:387)
[wsadmin] at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:694)
[wsadmin] at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(BaseStorage.java:152)
[wsadmin] at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStorage.java:129)
[wsadmin] at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:124)
[wsadmin] at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:138)
[wsadmin] at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:112)
[wsadmin] at org.eclipse.osgi.framework.internal.core.OSGi.createFramework(OSGi.java:90)
[wsadmin] at org.eclipse.osgi.framework.internal.core.OSGi.<init>(OSGi.java:31)
[wsadmin] at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:286)
[wsadmin] at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:173)
[wsadmin] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wsadmin] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[wsadmin] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[wsadmin] at java.lang.reflect.Method.invoke(Method.java:585)
[wsadmin] at org.eclipse.core.launcher.Main.invokeFramework(Main.java:340)
[wsadmin] at org.eclipse.core.launcher.Main.basicRun(Main.java:282)
[wsadmin] at org.eclipse.core.launcher.Main.run(Main.java:981)
[wsadmin] at com.ibm.wsspi.bootstrap.WSPreLauncher.launchEclipse(WSPreLauncher.java:340)
[wsadmin] at com.ibm.wsspi.bootstrap.WSPreLauncher.main(WSPreLauncher.java:110)
[wsadmin] WASX7448E: The trace file cannot be written to location /websphere/AppServer/profiles/logs/wsadmin.traceout . Ple
ase specify a different location with -tracefile option.

BUILD FAILED
/centive/downloads/Centive_4.3.2.319/Workbench/4.3.2.319/app-server/ant-scripts/build-core-config-was.xml:57: Java returned:
24
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:87)
at com.ibm.websphere.ant.tasks.WsAdmin.execute(WsAdmin.java:406)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:341)
at org.apache.tools.ant.Target.performTasks(Target.java:369)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
at org.apache.tools.ant.Main.runBuild(Main.java:668)
at org.apache.tools.ant.Main.startAnt(Main.java:187)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)

Total time: 7 seconds


Could you please tell me how to resolve this and change the log file location??
 
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Seems like a very similar problem to the one described at http://www-01.ibm.com/support/docview.wss?uid=swg21244631 . Most probably running your scripts as a non-root user, but somehow used root user for some configuration changes beforehand. If this is the case, you may check to see wheather instructions in this technote help;

- stop servers
- To see if that's the case use find <WAS_HOME> -owner root
- Change ownership to your non-root user (i.e. chown -R nonrootuser:nonrootusergroup <WAS_HOME>)
- Run <WAS_HOME>/profiles/<profile>/bin/osgiCfgInit.sh
- start servers
 
reply
    Bookmark Topic Watch Topic
  • New Topic