Win a copy of Beginning Java 17 Fundamentals: Object-Oriented Programming in Java 17 this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Unable to call webservice over SSL

 
Ranch Hand
Posts: 558
2
Hibernate Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello All,

We have a webservice that is deployed in our dev environment and a new certificate was installed for enabling SSL. I tried the URL in browser and I can access the service. But now I'm trying to access the service from a unit test. I added the server certificate to my local client truststore and added the trust store and password as system properties as given below




But when I run my test, I'm getting the exception



Is there anything I'm missing here. I could not understand much from this exception, except that it could not find the certification. But this certification is added to my client truststore without any issue. I can see that in the keystore.
 
Ranch Hand
Posts: 2198
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi!
The certificate that you use with the web service has to be signed by a CA (certificate authority), either directly or indirectly.
The exception you see is because there is a failure to verify that a CA root certificate is in a certificate path starting with your certificate.
This article will tell you how to bypass this problem in a development environment:
http://blogs.sun.com/andreas/entry/no_more_unable_to_find
Best wishes!
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic