• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

WAS 6.1 not starting with ANT script

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

i used the following script to start WAS 6.1 through command prompt.

<project default="default" name="WAS">
<path id="was.classpath">
<pathelement location="C:\Program Files\IBM\WebSphere\AppServer1\deploytool\itp\plugins\com.ibm.websphere.v61_6.1.0\ws_runtime.jar"/>
<pathelement location="C:\Program Files\IBM\WebSphere\AppServer1\bin" />
</path>
<taskdef name="startServer" classname="com.ibm.websphere.ant.tasks.StartServer" classpathref="was.classpath"/>

<target name="default" >
<startServer wasHome="C:/Program Files/IBM/WebSphere/AppServer1" server="AppServer1"/>
</target>
</project>


i get the following:

default:
Unable to parse setupCmdLine: null\bin\setupCmdLine.bat (The system cannot find the path specified)
Unable to parse setupCmdLine: null\bin\setupCmdLine.bat (The system cannot find the path specified)
[startServer] Unable to execute command
[startServer] at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:840)
[startServer] at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:436)
[startServer] at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:450)
[startServer] at org.apache.tools.ant.taskdefs.Java.fork(Java.java:746)
[startServer] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:170)
[startServer] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:83)
[startServer] at com.ibm.websphere.ant.tasks.ServerControl.execute(ServerControl.java:229)
[startServer] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
[startServer] at org.apache.tools.ant.Task.perform(Task.java:364)
[startServer] at org.apache.tools.ant.Target.execute(Target.java:341)
[startServer] at org.apache.tools.ant.Target.performTasks(Target.java:369)
[startServer] at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
[startServer] at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
[startServer] at org.apache.tools.ant.Main.runBuild(Main.java:673)
[startServer] at org.apache.tools.ant.Main.startAnt(Main.java:188)
[startServer] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[startServer] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[startServer] Caused by: java.lang.NullPointerException
[startServer] at java.lang.ProcessBuilder.start(ProcessBuilder.java:441)
[startServer] at java.lang.Runtime.exec(Runtime.java:591)
[startServer] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[startServer] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[startServer] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[startServer] at java.lang.reflect.Method.invoke(Method.java:585)
[startServer] at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:831)
[startServer] ... 16 more
[startServer] --- Nested Exception ---
[startServer] java.lang.NullPointerException
[startServer] at java.lang.ProcessBuilder.start(ProcessBuilder.java:441)
[startServer] at java.lang.Runtime.exec(Runtime.java:591)
[startServer] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[startServer] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[startServer] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[startServer] at java.lang.reflect.Method.invoke(Method.java:585)
[startServer] at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:831)
[startServer] at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:436)
[startServer] at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:450)
[startServer] at org.apache.tools.ant.taskdefs.Java.fork(Java.java:746)
[startServer] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:170)
[startServer] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:83)
[startServer] at com.ibm.websphere.ant.tasks.ServerControl.execute(ServerControl.java:229)
[startServer] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
[startServer] at org.apache.tools.ant.Task.perform(Task.java:364)
[startServer] at org.apache.tools.ant.Target.execute(Target.java:341)
[startServer] at org.apache.tools.ant.Target.performTasks(Target.java:369)
[startServer] at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
[startServer] at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
[startServer] at org.apache.tools.ant.Main.runBuild(Main.java:673)
[startServer] at org.apache.tools.ant.Main.startAnt(Main.java:188)
[startServer] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[startServer] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)


what else needs to be set inorder to find the file "setupCmdLine.bat" ?

is the wasHome attribute set properly ?
 
satish rp
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have found that the profilename attr. solved the problem and new problems are on plate!!!


i used the below

<startServer server="AppServer1" profilename="AppServer01" failonerror="true" wasHome="${local.websphere.path}" />


The problem now is:

java.util.MissingResourceException: Can't find bundle for base name com.ibm.ws.profile.resourcebundle.WSProfileResourceBundle, locale en_US


Any pointers ???
 
And when my army is complete, I will rule the world! But, for now, I'm going to be happy with this tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic