• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Maven surfire plugin ignores the POM cofiguration

 
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When Maven execute my test cases that use OpenJPA do I get an exception

That exception is solved if I add this JVM-option

which I have added to the run configuration in eclipse which then executes all my test cases sucessfully. To have them executed successfully of Maven also have I tried to add that JVM-option to the surfire plugin that executes the test cases with this configuration in the POM:

But it seems that the surfire plugin just ignores the configuration. I can't find any reason to why this should not work. Have I made anything wrong och could I configure this in another way?
 
Jonny Andersson
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I just found that the commandis a workaround to this problem but it would be a lot better if this JVM option could be configured in the POM instead
 
author
Posts: 3285
13
Mac OS X Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Run maven with debug logging on and see what that line gets translated to, you might need to escape the backslashes for example
reply
    Bookmark Topic Watch Topic
  • New Topic