Win a copy of Escape Velocity: Better Metrics for Agile Teams this week in the Agile and Other Processes forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Frank Carver
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • fred rosenberger

Deployment Error in Websphere Application Server 7

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

my application was successfully running in websphere application server 6 perfectly. now i want to deploy my application in Websphere version 7. during deployment i am getting the following error....

[12/17/10 17:15:58:155 WST] 00000020 SystemOut O DefaultInit: init
[12/17/10 17:15:58:167 WST] 00000020 SystemOut O DefaultInit: Setting default XML parser factory to Xerces
[12/17/10 17:15:58:306 WST] 00000020 servlet E com.ibm.ws.webcontainer.servlet.ServletWrapper init SRVE0100E: Uncaught init() exception created by servlet DefaultInit in application amb: java.lang.VerifyError: JVMVRFY027 receiver is incompatible with declaring class; class=com/jcorporate/expresso/core/logging/LogManager, method=initialize()V, pc=336


by the way may i know is there any direcotory in Websphere like tomcat common directory..

 
Ranch Hand
Posts: 446
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Have you recompiled your classes in WAS 7.x libraries before deploying it? Also you need to made sure that all third party libs used by your app are also upgraded to JDK 1.6 level.

The error message indicates that WAS is throwing java.lang.Verify Error...
 
ajana pothik
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
thanks for your feedback. my third party lib already works with 1.6 jdk. i have tested this same application in glassfish server which run on 1.6.

i have compiled it today in was 7 environment. let me check today, i will come back to you if its still show me the same error.
 
Eat that pie! EAT IT! Now read this tiny ad. READ IT!
The trailboss has a kickstarter
https://coderanch.com/t/754577/Garden-Master-kickstarter
reply
    Bookmark Topic Watch Topic
  • New Topic