• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Jj Roberts
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Himai Minh
  • Carey Brown
  • salvin francis

deploy.wsdd AxisFault

 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

I have created a webservice and tried to deploy it but am getting this error:

Processing file deployIdCliWS3.wsdd
Exception: AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
faultSubcode:
faultString: Couldn't find an appropriate operation for XML QName {http://xml.apache.org/axis/wsdd/}deployment
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}hostname:jslee1


I´m not sure what information to provide to the Topic.

This is the deploy.wsdd file:

<deployment
xmlns="http://xml.apache.org/axis/wsdd/"
xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">

<!-- Services from IdCliService WSDL service -->

<service name="IdCliPort" provider="java:RPC" style="wrapped" use="literal">
<parameter name="wsdlTargetNamespace" value="uri:IdCli.ws.tid.es"/>
<parameter name="wsdlServiceElement" value="IdCliService"/>
<parameter name="schemaQualified" value="uri:IdCli.ws.tid.es"/>
<parameter name="wsdlServicePort" value="IdCliPort"/>
<parameter name="className" value="es.tid.ws.IdCli.generated.IdCliPortSoapBindingImpl"/>
<parameter name="wsdlPortType" value="IdCli"/>
<parameter name="typeMappingVersion" value="1.2"/>
<operation name="idCliOp" qname="operNS:idCliOp" xmlns:operNS="uri:IdCli.ws.tid.es" returnQName="retNS:idCliOpReturn" xmlns:retNS="uri:IdCli.ws.tid.es" returnType="rtns:IdCliResult" xmlns:rtns="uri:IdCli.ws.tid.es" soapAction="" >
<parameter qname="pns:in0" xmlns:pns="uri:IdCli.ws.tid.es" type="tns:string" xmlns:tns="http://www.w3.org/2001/XMLSchema"/>
</operation>
<parameter name="allowedMethods" value="idCliOp"/>

<arrayMapping
xmlns:ns="uri:IdCli.ws.tid.es"
qname="ns:ArrayOfLlamada"
type="java:es.tid.ws.IdCli.generated.Llamada[]"
innerType="cmp-ns:Llamada" xmlns:cmp-ns="uri:IdCli.ws.tid.es"
encodingStyle=""
/>
<typeMapping
xmlns:ns="uri:IdCli.ws.tid.es"
qname="ns:IdCliResult"
type="java:es.tid.ws.IdCli.generated.IdCliResult"
serializer="org.apache.axis.encoding.ser.BeanSerializerFactory"
deserializer="org.apache.axis.encoding.ser.BeanDeserializerFactory"
encodingStyle=""
/>
<typeMapping
xmlns:ns="uri:IdCli.ws.tid.es"
qname="ns:Llamada"
type="java:es.tid.ws.IdCli.generated.Llamada"
serializer="org.apache.axis.encoding.ser.BeanSerializerFactory"
deserializer="org.apache.axis.encoding.ser.BeanDeserializerFactory"
encodingStyle=""
/>
</service>
</deployment>
 
Karen Castillo
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

This issue was solved by updating and restarting axis in weblogic. At some moment during deploying and undeploying axis needed a restart.
 
Get me the mayor's office! I need to tell her about this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic