Last week, we had the author of TDD for a Shopping Website LiveProject. Friday at 11am Ranch time, Steven Solomon will be hosting a live TDD session just for us. See for the agenda and registration link
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

ajp with mod_jk and 503 error

 
Ranch Hand
Posts: 54
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

I use ajp13 on our dev box with tomcat 6.0.20 on solaris
It is used to not show the port number and to show a standard domain address we use for all apps.
It is working fine in development.

I took the same configuration and tried to set up test environment, but I keep getting

Failure of server APACHE bridge:


--------------------------------------------------------------------------------
No backend server available for connection: timed out after 10 seconds or idempotent set to O

The application is still available if I go directly to the server it is on and use port 8080.

In addition, if I run netstat -a, I see port 8009 listening.
I ran snoop on the server with tomcat and see no attempt by the apache server (located on another server) to even go to D=8009.

On the apache server, I see in its mod_jk.log it sees the following:

[Mon Jan 17 13:03:36 2011][3674:1] [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/
apps/jira/*=jira' source 'JkMount'
[Mon Jan 17 13:03:36 2011][3674:1] [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/
apps/jira=jira' source 'JkMount'
[Mon Jan 17 13:03:36 2011][3674:1] [debug] jk_map_to_storage::mod_jk.c (3603): no match for /index.html found

This seems to indicate it sees the JkMount rules. The fact snoop does not see any port attempt seems to indicate that it does not even try to go to my tomcat server (or is this not the case?) . I do not think it should try index.html. I think jira uses default.jsp.

Does anybody have any ideas on what I could check or different methods to see what might be going on?

My mod_jk.conf (included in httpd.conf):

<code>
# Load mod_jk module
# Update this path to match your modules location
LoadModule jk_module modules/mod_jk.so

# Where to find workers.properties
# Update this path to match your conf directory location
JkWorkersFile /opt/coolstack/apache2/conf/extra/workers.properties

# Where to put jk logs
# Update this path to match your logs directory location
JkLogFile /opt/coolstack/apache2/logs/mod_jk.log

# Set the jk log level [debug/error/info]
JkLogLevel debug

# Select the log format
JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"

# JkOptions indicate to send SSL KEY SIZE,
JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories

# JkRequestLogFormat set the request format
JkRequestLogFormat "%w %V %T"
</code>

Lines in worker.properties:
<code>
worker.list=jira
worker.jira.type=ajp13
worker.jira.host=mistomt01.unx.sas.com
worker.jira.port=8009
</code>


 
Come have lunch with me Arthur. Adventure will follow. This tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic